TECO AC Soft Starter

Reply

  #1  
Old 05-28-08, 08:19 PM
Member
Thread Starter
Join Date: May 2008
Posts: 8
Received 0 Votes on 0 Posts
Talking TECO AC Soft Starter

Compressor only runs a few seconds when started !!The outdoor unit on my TECO split system has a module encased in resign. By the looks this is some sort of relay/timer module to switch between the compressors start & run windings. As the comp. starts but only runs for a few seconds then stops when it's contactor pulls in, I am assuming this "DETRON ACS-II" module is at fault. Does anyone know what components are encased in this resign box? Or can I use a standard timer with changeover contacts to replace it?

Thanks
David.
 
Sponsored Links
  #2  
Old 10-05-08, 01:50 AM
Member
Join Date: Oct 2008
Location: Newcastle NSW Australia
Posts: 1
Received 0 Votes on 0 Posts
Originally Posted by DEBrooksy View Post
Compressor only runs a few seconds when started !!The outdoor unit on my TECO split system has a module encased in resign. By the looks this is some sort of relay/timer module to switch between the compressors start & run windings. As the comp. starts but only runs for a few seconds then stops when it's contactor pulls in, I am assuming this "DETRON ACS-II" module is at fault. Does anyone know what components are encased in this resign box? Or can I use a standard timer with changeover contacts to replace it?

Thanks
David.
Teco AC Soft Starter
Hi David,
I'm afraid I can't help but am experiencing exactly same symptoms & wonder whether u found a solution & if so what it was. Many thanks in anticipation .. John Gillard Australia
 

Last edited by HotxxxxxxxOKC; 10-05-08 at 06:53 AM. Reason: email removed. Spam prevention
  #3  
Old 01-21-10, 03:10 PM
Member
Join Date: Jan 2010
Location: Gladstone, QLD (Australia)
Posts: 1
Received 0 Votes on 0 Posts
I had two faults on my Kelvinator split unit...first, the unit would run a few seconds and trip off, as you are experiencing...the second is that the unit would run but the compressor would not kick in.

The first issue was a faulty Detron ACS-series starter...the second issue was the faulty starter coupled with a failed run capacitor.

I just fixed my unit last night...I got the capacitor from a local industrial motor shop, and I got the starter from a refrigeration mechanic friend who purchased it from an industrial refrigeration dealer.
 
  #4  
Old 02-19-13, 02:59 AM
Member
Join Date: Feb 2013
Location: Australia
Posts: 1
Received 0 Votes on 0 Posts
Kelvinator RAC KWJ62HRA

This unit has a DETRON ACS2 - 1 control unit with a 24 volt a.c. relay on board. After the designed time delay of approx 3 minutes 1.9 volts appears across the coil terminals, of course not enough to activate it.
Does anyone have a circuit diagram for this resin encased controller please?

kind regards, Rodders
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: