York Diamond 80 Open Limit


  #1  
Old 01-05-09, 08:07 PM
R
Member
Thread Starter
Join Date: Jan 2009
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
York Diamond 80 Open Limit

My York Diamond 80 hvac is about 12 years old.

The blower motor is not comming up during the heating. The LED indicator is telling "Open Limit". All vents are open. This sittuation is the same if I keep the door open and keep pressing the button.

I read in other posts metionting that the problem might be the GE capacitor I can't find the specification looking at the label.

It reads
+06 -06% 50/60Hz
Protected P921
A10000AFC 5033GH05
DIELEKTROL VI
024-20045.

Does anyone know what should I choose in the list (dielektrol, Business Industrial items on eBay.com

Thanks for any help.
 
  #2  
Old 01-08-09, 08:28 PM
D
Member
Join Date: Aug 2007
Posts: 2,021
Upvotes: 0
Received 0 Upvotes on 0 Posts
You need to see if it has an mfd or uf rating and a vac rating. The VAC is probably 370. Perhaps you could take out the motor and see if it has a capacitor rating. Does the motor try to start? Are you getting voltage to the motor?
 
  #3  
Old 01-11-09, 07:37 PM
xpogi's Avatar
Member
Join Date: Dec 2008
Location: Kansas
Posts: 102
Upvotes: 0
Received 0 Upvotes on 0 Posts
Originally Posted by rato2009 View Post
My York Diamond 80 hvac is about 12 years old. The blower motor is not comming up during the heating. The LED indicator is telling "Open Limit".
Does the blower come on when you turn the fan switch on the thermostat to "On". If that is the case there is probably a control problem not a motor or capacitor problem.

If the blower runs then you will likely need to reset the manual reset limit in the blower compartment and then you can run the blower continuously while in the heating mode so you can have some heat in your house while you troubleshoot the problem.
Is the wire coming from the motor and connected to the "Heat" terminal on the control board loose?
The problem may well be a faulty control board.
 
  #4  
Old 01-17-10, 05:54 PM
R
Member
Join Date: Jan 2010
Location: michigan
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
Question

Hi, I have a York Diamond 80 Open Limit unit. Suddenly the blower motor will not start. I removed it can't see any obvious problem. All wires are secure, the motor, fan and housing are all clean. I can hear the motor kickin, I actually see it move but will not fully engage. If I assist it with a small push, it will run. But, it rotates clockwise and counter-clockwise depending the direction I push. After running for 1-2 minutes, the motor starts to get hot.
This unit has a capacitor (10uf, 370 VAC, +06 -06%), could it be bad or is it the motor. What's the best way to go?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: