problem with Simple Comfort 2001 thermostat


  #1  
Old 07-01-10, 02:00 PM
M
Member
Thread Starter
Join Date: Jul 2010
Location: USA
Posts: 1
Upvotes: 0
Received 0 Upvotes on 0 Posts
problem with Simple Comfort 2001 thermostat

Found that one of the kids has been hiding a door key INSIDE the thermostat device- that's right, a piece of metal shoved into the device between the wires and the exposed circuit board!

So I'm not sure the A/C system is working properly now- the inside and outside units seem to be working, and cold air is blowing, but the temp reading isn't going down on the thermostat display (and therefore the system stays on all the time). I can't actually tell if it is that hot in the upstairs hallway where the 'stat is located (don't have a thermometer on hand), but it certainly doesn't seem as cold as it should be.

Could something have been shorted out?

There is a loose white wire inside the unit, but not sure if that was that way from when it was installed. Where should that white wire go? (we have elec. heat and a/c).

Any help is appreciated!

Mark
 
  #2  
Old 07-01-10, 06:01 PM
Z
Member
Join Date: Jan 2008
Location: Southeastern Pennsylvania
Posts: 3,438
Received 135 Upvotes on 126 Posts
hi mark -

I don't know diddly but I just installed a new a/c thermostat so I've been into things for a while trying to understand thermostats. Found your manual on this link:

http://www.icmcontrols.com/spanish/d...msc2001_ag.pdf

On pages 6 an 11 it shows W is connected to heating control. Maybe you have a separate thermostat for heat - that's what I have. Maybe that's why white is not connected internally.

Hope someone knowledgeable helps you out!

Good luck!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: