2003 Bryant AC - Icing Over

Reply

  #1  
Old 07-03-11, 10:46 AM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
2003 Bryant AC - Icing Over

My AC unit stopped cooling, then eventually cut off due to icing over. Temps in the house reached as high as 90. Repairman came, checked pressure, checked filter, tightened some valves. He didn't have the right coolant so he sent another repairman over. The new repairman checked pressure and added 1lb coolant. He said he could not stay to see what effect it had on the pressure as it was so hot in the house. He said if it didn't work to call him as it may be the expansion coil valve not releasing coolant properly.

After the repairman left, the temp would drop a degree each hour. Took 6-7 hours to go from 88 to 76. Overnight went down to 74 as programmed. Worked fine the next day, but hovered at 78/79 when set to 76. As the days past, it slowly got worse. Downstairs vents blowing more cool air than upstairs. Upstairs vents blowing cool but less air coming out. (Was the same last year when I first purchased the home.)

Yesterday we were back up to 86 in the house. Much hotter upstairs so I closed a few of the vents downstairs to help cool upstairs better. (Not sure if that was the right thing to do) Last night the unit cut off due to icing. Fan has pretty much been on continuously. I called and spoke to the repairman who stated he has to replace Expansion Coil due to malfunctioning valve.

History - Previous owners never had ducts cleaned, had lines flushed for algae and filter changes only. Unit worked well for them.

Questions:
Could the unit just need to be flushed again? (I have added bleach to the pipes each year as I was told to do)
Could it be a duct issue? (Repairmen never checked ducts in attic, etc.)
If need to replace the TEV, why do we have to replace coils as well? (There was no mention of a coil leak and it is my understanding that these are two different items with very different pricing)
Quoted just under a grand to replace the coil/valve and told it would take an hour or so. Is that accurate? (I have seen online that it takes 3-4 hrs to change a coil)

I am a new homeowner and a single woman who doesn't know much about this stuff. I would love a honest opinion or to know of some troubleshooting things I can do to see if it is something else. Thank you!
 
  #2  
Old 07-03-11, 03:22 PM
C
Member
Join Date: Aug 2008
Location: Texas, California
Posts: 1,498
Received 1 Vote on 1 Post
From what you said, I think you have a coolant leak, that is why it works fine after he filled the system up. In normal situation, it should stay that way, but after a day, the coolant slowly leaks out(that is why the system getting worse slowly) , and that is why the system icing again and does not cool anymore. Call another AC tech and ask him to check the coolant again, if it is low, tell him that you added the coolant just two days ago,(two days means -- big leak, he should be able to find it) ask him to find and if possible, repair the leak. (I would not trust the fisrt AC tech. this is not the valve problem, if the valve has problem, you won't get cool air even the first day. Let's hope the leak is not in the coil, if it is, then you need a new coil)
 
  #3  
Old 07-04-11, 04:41 PM
G
Member
Join Date: Oct 2008
Location: USA
Posts: 3,012
Received 13 Votes on 13 Posts
Originally Posted by TEXNGRRL View Post
The new repairman checked pressure and added 1lb coolant. He said he could not stay to see what effect it had on the pressure as it was so hot in the house.
Too hot to get a good measurement (nonsense) or too hot for him to stick around? Did he even hook up gauges at the outside condenser unit? If not, how would he decide to add one pound? I doubt that just being low by one pound would cause the problem.

If the refrigerent is (or was) low, there can be one and only one reason - there is a leak.
 
  #4  
Old 07-05-11, 09:46 AM
T
Member
Thread Starter
Join Date: Jul 2011
Location: USA
Posts: 2
Received 0 Votes on 0 Posts
Thank you gilmorrie and clocert for your quick responses. I am so glad I took the advice and had a different repairman come out. His company was very highly rated online and now I know why. He came out on July 4th and checked everything out. It turns out it was not a leak, a coil, or the exhaust valve. It was simply that the clogged pipes needed to be flushed and because they were level, the water kept building up and then overflowing until the safety switch valve turned the unit off. He repositioned the pipes so that they sloped downward a little bit more and he flushed them out. He stuck around for an hour checking out everything to make sure there wasn't a leak or freezing issue. He said I probably didn't need the Freon the other tech added (if he added it - which we are not 100% sure about) and he said I definitely didn't need a coil or exhaust valve. He was awesome and charged me a dollar more than the other guy who spent 15 min with me. I have a new AC company for life now. He is going to do all of my annual maintenance. It's nice to know there are still some people out there who care and who aren't trying to rip you off!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: