CH & Air Not Blowing

Reply

  #1  
Old 09-18-12, 07:39 AM
Member
Thread Starter
Join Date: Sep 2012
Location: USA
Posts: 9
CH & Air Not Blowing

My unit is about 7-8 years old. The unit will run outside but nothing comes out of the vents in the house. It is a single unit, electric air and gas heat. The blower motor should not be bad right. Is there something that would cause the blower to not spin, a relay or something? New blower is about $600 that I don't have.
 
Sponsored Links
  #2  
Old 09-18-12, 08:17 AM
Member
Thread Starter
Join Date: Sep 2012
Location: USA
Posts: 9
Unit not blowing

The unit has been off for 2 hrs and it is now blowing some. I can hear the blower motor runing with the fan on. I can look in the unit and see ice on the condensor? blue cylinder a foot tall and on the lines. This unit is only about 7 years old. It should not be leaking freon. I know low freon will cause the lines to freeze up. Will a dirty air filter also cause this? The filter is dirty and I noticed it was being sucked more into the return than normal.
 
  #3  
Old 09-18-12, 12:28 PM
Member
Thread Starter
Join Date: Sep 2012
Location: USA
Posts: 9
Ok the unit is thawed and a new filter installed. Seems to be blowing fine. Would a dirty filter cause this or is it low on freon? Why would it be low its 7 yrs old.
 
  #4  
Old 09-18-12, 06:10 PM
hvactechfw's Avatar
Member
Join Date: Jan 2011
Posts: 6,245
a plugged filter would cause the problem. I would wait to see how it does with everything thawed out. If it freezes again then you need to have the charge checked by a pro.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes