Compressor not kicking in


  #1  
Old 05-15-14, 05:17 PM
W
Member
Thread Starter
Join Date: May 2014
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Compressor not kicking in

So i have a central air unit made by goodman. Ive has compressor replaced about 3 yrs ago. I wasnt previous owner. Last year i started noticing this and its happening once again. When i turn the unit on for first time. Meaning its been off couple days or was on heat. The compressor fan spins but the unit isnt actually blowing cold air. After a bit it then kicks on. What i did a few times was i actually turned breaker off assuming maybe power glitch and don't know if coincidence but has worked. Last week i tried that didnt work but like with a minute or two later it kicked in cold air. Any idea. Could be bad thermostat?
 
  #2  
Old 05-15-14, 05:35 PM
Bob14525's Avatar
Member
Join Date: Jun 2013
Location: USA
Posts: 1,744
Received 51 Likes on 44 Posts
If you're seeing the condensor fan running (outdoor unit) it's not the thermostat or contactor. If either of them were bad, the outdoor unit wouldn't be running.
 
  #3  
Old 05-15-14, 05:42 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 70,925
Received 3,162 Likes on 2,841 Posts
Welcome to the forums.

Is this a straight air conditioner or a heat pump system ?
 
  #4  
Old 05-15-14, 05:55 PM
W
Member
Thread Starter
Join Date: May 2014
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Its got both heat and air. The fan does spin outside but its not cold inside. Then you hear the noise like compressor kicked in and becomes cold air.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: