Copper Tubing to AC Condenser Covered with Ice

Reply

  #1  
Old 06-23-15, 12:02 PM
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 206
Received 0 Votes on 0 Posts
Copper Tubing to AC Condenser Covered with Ice

The copper tubing going to my condenser unit has frozen over perhaps 2-3 times this year. The last couple of times, I turned off the AC and let it thaw, then turned it back on. What causes that to happen? I've noticed the wrap around the copper tubing has come partially undone. Could this be contributing or causing the problem?

Thanks in advance.
 
Sponsored Links
  #2  
Old 06-23-15, 12:07 PM
airman.1994's Avatar
Member
Join Date: Dec 2005
Location: VA
Posts: 5,769
Received 4 Votes on 4 Posts
Your unit has an issue. Call a repairman. It either has a leak and needs refrigerant or it has a air movement issue.
 
  #3  
Old 06-23-15, 12:09 PM
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 206
Received 0 Votes on 0 Posts
Thank you, airman. We'll give them a call.
 
  #4  
Old 06-23-15, 12:17 PM
Member
Thread Starter
Join Date: Apr 2011
Location: USA
Posts: 206
Received 0 Votes on 0 Posts
Air Movement

Think it may be an air movement issue as you suggested, airman. Thought I had changing my filter set up as a recurring event on my calendar. Apparently I didn't recur it far enough out. I'm a couple of months over due for a change. I'll give that a try first after thawing. Thanks again.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: