Awful noise from old Bryant Quantum 552a

Reply

  #1  
Old 07-18-16, 03:00 PM
W
Member
Thread Starter
Join Date: Dec 2015
Posts: 10
Received 0 Votes on 0 Posts
Awful noise from old Bryant Quantum 552a

https://www.youtube.com/watch?v=Aa5gUJ1PazI It sounds much worse in real life than it does in the vid.

I am guessing compressor since the fan keeps running...just trying to narrow it down before I call the oh so expensive repair professional.

Background: this is a Bryant Quantum 552a circa late 80's I believe.

I replaced the capacitor on it a few weeks ago after it stopped blowing cold. It has been blowing cold since and seems to be working well aside from the awful noise.
 
Sponsored Links
  #2  
Old 07-18-16, 03:14 PM
S
Member
Join Date: Feb 2014
Location: USA
Posts: 2,104
Received 0 Votes on 0 Posts
Sounds like the contactor is going on and off. Check the 24V to the contactor when it's doing that.
 
  #3  
Old 07-18-16, 03:21 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 58,642
Received 1,049 Votes on 973 Posts
It sounds like you have multiple problems.

Yes.... I agree that the contactor is chattering. I'm thinking low on refrigerant and the low pressure switch activating.

It also sounds like the fan motor is wiped.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: