Compressor Not Turning On, Please Help!

Reply

  #1  
Old 10-02-18, 05:25 PM
Member
Thread Starter
Join Date: Sep 2018
Posts: 3
Compressor Not Turning On, Please Help!

I have a commercial Portable AC unit, 18,000 BTU. It's a Northwind Mac1811 model. The compressor is currently not coming on and only the fan is running. I have tested the contactor and am getting 120 V and 24V. The contactor is turning on after approximately a 2 minute delay and I show 120 voltsat the top of the contactor. I also show power at the run capacitor (only powers compressor), hard start kit, and the compressor wires once the contactor turns on. This was verified by a Fluke voltage detector but now sure how many volts these are getting.

The unit is running at approximately 2 amps before the contactor goes on then when the contactor turns on it goes up to approximately 3.75 amps as verified by a Killowat plug. Before I was having problems I'm pretty sure the machine would run at approximately 3.5 amps with the contactor closed and once it opened I would get approximately 14 amps when the compressor turned on. I have noticed that sometimes the contactor will turn on as soon as I plug in the unit if the fan is on and won't wait for the delay. I also just saw the contactor turn on when the unit was plugged in but the power button was turned to off.

It appears the power on/off switch no longer completely turns off the fan. For example If I have the fan/ac set to the on position on the front of the control panel and I switch the main power switch to off the fan stays on. When the main power button is turned off and the unit is plugged in I am getting 24v and no 120 at the contactor. When the main power button is turned on I am getting 120v and 24v at the contactor. Also the time delay load in is getting power at all times even with the off switch turned off. Not sure if it should be this way. I also noticed recently the compressor would try and start and the amps would momentarily shoot up to 25 amps before coming back down quickly and the compressor would not start. I would then unplug and plug back in the machine and the compressor would eventually turn on. I appreciate any help on troubleshooting this...
 
Sponsored Links
  #2  
Old 10-02-18, 06:20 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 45,583
The good news is that since this is a quality unit.... there is a manual available for it.
I need to look it over.

Northwind Mac service manual
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes