Contactor clicking rapidly while running

Reply

  #1  
Old 06-07-19, 06:35 AM
Member
Thread Starter
Join Date: Jun 2019
Location: USA
Posts: 1
Angry Contactor clicking rapidly while running

I searched the forms only came across post where the AC would not turn on, so maybe I am asking the wrong question but decided to ask for help.

Two days ago I reached out to a friend in HVAC when I started hearing a clicking sound, he ended up replacing the contactor and problem solved until this morning when I started hearing the clicking sound again. Today, the clicking has become more rapid/violent, so I am reaching out for help to see if there is anything I can do before asking or calling for help.

Facts:
goodman ckl42-1a (installed 2001) no leaks, no major repairs. clear of debris.
New contactor - voltage held steady on the old contactor, even while the switch was clicking but I don't recall the voltage. 24 I think.
Ecobee 3 thermostat - installed by the power company 2+ years ago

thanks in advance for any help.
 
Sponsored Links
  #2  
Old 06-07-19, 09:31 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 50,954
Likes Received: 155
Welcome to the forums.

As a guess....... you are low on refrigerant and the contactor is opening on low pressure. As soon as the compressor stops..... the pressure rises and the contactor closes again. This can go on and on.
(don't allow it to run like that..... it can very damaging)

If you're slightly low it happens when it's cooler outside. Once it gets hot it happens less.
You'll need to have the charge checked.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes