Lennox HVAC not cooling and heating

Reply

  #1  
Old 06-18-19, 07:13 PM
Member
Thread Starter
Join Date: Jun 2019
Location: United States
Posts: 1
Lennox HVAC not cooling and heating

Hey everyone, I have a Lennox model LRP14HP48P and it seems to not be heating or cooling no matter what I set the thermostat to. All I know for sure is that the fan works when I switch it from auto to on. However, when I switch it to cooling or heating, I hear nothing and nothing happens. Any suggestions? Thanks!
 
Sponsored Links
  #2  
Old 06-18-19, 07:57 PM
Member
Join Date: Oct 2016
Posts: 1,189
Upvotes Received: 26
First thing to do is check for a call for heating/cooling with your meter. If the blower works then you know the transformer is working.
 
  #3  
Old 06-18-19, 08:07 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 51,376
Upvotes Received: 206
Welcome to the forums.

Are you going to troubleshoot and work on that unit ?
That's a 4 ton packaged heat pump. The blower is working which means the unit has power.
There may be more than one circuit breaker controlling that unit.
Does this unit have electric heat for winter backup ? See if that's working.

Next step is using a meter to check for power on the thermostat terminals inside the unit. If it isn't a thermostat problem then it may be the system is low on refrigerant and the safety pressure switches are keeping it from starting.

LRP14HP manual (pdf)
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes