Correct Replacement Run Capacitor

Reply

  #1  
Old 10-28-19, 06:26 PM
Member
Thread Starter
Join Date: Nov 2004
Location: So Cal
Posts: 155
Received 3 Votes on 3 Posts
Correct Replacement Run Capacitor

My Lennox gave it up and will not start. The run capacitor is clearly bad. It is very badly domed and I can't get any reading with my meter for either HERM or Fan. So I ordered a GE Gentec 70 mfd 10 mfd 370VAC to replace a CDC 70 mfd 10 mfd 370VAC , but now I note one difference. The one being replaced is +/- 10% and the replacement is rated +8 for the 70 and -8% for the Fan. I think. It is hard reading that part of the label in the photo on the web. I am guessing that is just a printing mistake and it should have been marked +8-8%.

https://www.amazon.com/Genteq-Round-...307324&sr=8-12

Anyway, my question is should I install it and if it works go with it? It isn't due to be delivered for a couple of days.
 
Sponsored Links
  #2  
Old 10-28-19, 06:41 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,257
Received 482 Votes on 452 Posts
That Genteq cap will be fine for your application.
 
klawman213 voted this post useful.
  #3  
Old 10-28-19, 08:18 PM
Houston204's Avatar
Forum Topic Moderator
Join Date: Oct 2009
Location: Texas
Posts: 7,417
Received 14 Votes on 11 Posts
The new cap is rated to be within 8% of spec and the old cap was rated to be within 10% of spec.

The new cap is better.
 
  #4  
Old 10-28-19, 09:14 PM
Member
Thread Starter
Join Date: Nov 2004
Location: So Cal
Posts: 155
Received 3 Votes on 3 Posts
Cool. Thanks to both of you. I guessed but wasn't sure that the 8 percenter was actually rated slightly better. Now to see if it starts and if it does if there is any indication of what caused the capacitor to fail.
 
  #5  
Old 10-28-19, 10:04 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,257
Received 482 Votes on 452 Posts
Caps just dry out from heat and age.
 
  #6  
Old 10-30-19, 07:25 PM
Member
Thread Starter
Join Date: Nov 2004
Location: So Cal
Posts: 155
Received 3 Votes on 3 Posts
Thanks to all. I had the new capacitor tested and installed in 10 minutes after it arrived and the ac started right up and ran smooth.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: