My Fieldpiece SRL8 malfunction: Died and now wont turn on.


  #1  
Old 12-10-22, 07:43 PM
M
Member
Thread Starter
Join Date: Sep 2022
Location: United States
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
My Fieldpiece SRL8 malfunction: Died and now wont turn on.

After it was running for a while today, my SRL8 refrigerant detector died and will not turn back on now. I tried plugging it into the AC wall plug charger but the red light that usually comes on and starts blinking to indicate that it's charging doesn't even come on. I've tried pressing and holding the off/on button a number of times since but have had no luck so far. Could it possibly be the battery is so dead that the charger just wont charge it anymore? Anyone have any ideas on how I might fix this?
 
  #2  
Old 12-11-22, 06:54 AM
Geochurchi's Avatar
Member
Join Date: Nov 2012
Posts: 5,622
Received 157 Upvotes on 143 Posts
Hi, do you have this manual?
https://www.fieldpiece.com/wp-conten...n-SRL8-web.pdf
Geo🇺🇸
 
  #3  
Old 12-11-22, 10:38 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 71,663
Received 3,328 Upvotes on 2,987 Posts
How old is the unit ?

It won't charge with the wall charger. Did you try the mobile charger ?
 
  #4  
Old 12-11-22, 08:37 PM
M
Member
Thread Starter
Join Date: Sep 2022
Location: United States
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Yeah, Geochurchi, I think that's the same one that came with the meter. But thanks for making it available anyway.


Pjmax, I bought the unit about three years ago and, other than killing the first battery, I haven't really had any trouble until now. I also tried using the mobile charger today but still will not turn on.

Could it possibly be just a dead battery?
 
  #5  
Old 12-12-22, 05:50 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 71,663
Received 3,328 Upvotes on 2,987 Posts
If you have the same problem with both chargers it would indicate a battery problem.
The sensor can also fail but I think the unit still power up.
 
  #6  
Old 12-13-22, 03:34 PM
M
Member
Thread Starter
Join Date: Sep 2022
Location: United States
Posts: 6
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks, Pj. I was thinking it might be the battery because I just installed a new sensor today and it still will not start. I'm going to try to check the battery power to see if it's still charged.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: