Gas fired Boiler working but no heat on 1st floor


  #1  
Old 11-13-04, 10:12 PM
joannyc
Visiting Guest
Posts: n/a
Question Gas fired Boiler working but no heat on 1st floor

I have a Hydrotherm Gas Fired Boiler; Model HC125. It seems to be working fine (the boiler room is nice & warm). I am getting heat on 2nd floor of my house from the baseboards (the 2nd floor does have it's own thermostat, if that matters). There is no heat at all coming from the 1st floor baseboards, they are cold. Last winter my pipes froze and burst on the first floor reulting in the replacement/repair of all the baseboard pipes on the 1st floor.
Am I forgetting something I'm supposed to do to the boiler, Bleeding? Purging? Kicking? I keep going out to the boiler and looking at it, opening & closing valves etc. There are so many knobs and such. There does not seem to be any way to bleed air from the baseboards themselves.
Yeah I have NO idea what I'm doing! Any help or advice would be appreciated.
Thanks, Joan
 
  #2  
Old 11-14-04, 07:10 PM
rontram
Visiting Guest
Posts: n/a
You should have a purge valve for each zone, usually located on the return side of the loop. There should be a stop valve just after it. Close that valve and open the purge valve. You may want to attach a hose to it first. Allow the water to flow until all the air is out of the loop and it runs clear. Opening the feed valve to the full flow position will speed things up. Just don't forget to return it to the normal position before closing the purge valve. Good luck.

Ron
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: