Boiler stopping after a few secs


  #1  
Old 01-26-05, 06:29 AM
Paulh0202
Visiting Guest
Posts: n/a
Boiler stopping after a few secs

Trianco TR 28/32 BP oil boiler (about 12 years old).

Press red reset button and boiler start up sequence begins. After about 10 secs the boiler cuts out with red light on. Red reset button won't work again for about a minute.

Any ideas? Thought it might possibly be an oil/jet blockage of some sort although the boiler was services a couple of months ago and the jet renewed.
 
  #2  
Old 01-26-05, 02:21 PM
KField's Avatar
Member
Join Date: Dec 2002
Location: Easton, PA
Posts: 3,015
Upvotes: 0
Received 0 Upvotes on 0 Posts
The control will lock out when there is no flame for 15-45 seconds. Or when it thinks there is no flame. It could be a dirty flame sensor, poor flame, or a host of things that cause the safety control to do its job. If you stand by during the run cycle and observe something unusual, it would be helpful to know.

Ken
 
  #3  
Old 01-26-05, 04:43 PM
Paulh0202
Visiting Guest
Posts: n/a
As far as I can see there isn't a flame - don't think the burner's lighting up - 10 secs and it cuts out again on lock-up.

I spoke to Trianco and they seem to think it's one of 3 things - low oil (nope -checked that already, it's at least half full), the fire protection valve or dirt in the system. I'm suspecting the latter. However, I'm going to get the service guy out tomorrow and see what he says. Just didn't fancy treading into the unknown because they usually try and sell you bits that are OK while they're at it.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: