help asap w/burnham independence


  #1  
Old 10-23-05, 01:15 AM
T
Member
Thread Starter
Join Date: Oct 2005
Posts: 2
Upvotes: 0
Received 0 Upvotes on 0 Posts
help asap w/burnham independence

I have a burnham independence series boiler in my condo. something is up with it. last week the water level in the tube was fine, this morning when i went downstairs to check something i noticed there is no water in the tube. when i turned the water feed on, water came leaking out of the pipes that go up to the radiators so i turned the radiators on. seemed to clear things up but still no water in the tube. tonite the radiators started banging like crazy. woke me out of a dead sleep.i went back to the basement, noticed the psi on the boiler was at zero. figured it needs water as tube was still empty. started filling boiler, psi moved to 15, still no water in the tube but the banging stopped. what is going on with the water level? is it broken?? can someone please help? i am first time home owner and a bit worried.
i should ad that since the water is clear and the tube is clear it is possible that the tube is completely filled with water as opposed to empty, but it looks empty to me. also, the copper tube that drains the water out of the boiler seems to be dripping a bit. thanks to anyone who reads this and may have some input.
 
  #2  
Old 10-23-05, 11:13 AM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
Steam Boiler

I would bet my bottom dollar the system is flooded. No way should you have 15 psig on that boiler. Shut off the water feed & drain water. After a while you should see water in the sight glass.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: