Boiler and General Questions


  #1  
Old 10-27-05, 09:03 AM
dixie77
Visiting Guest
Posts: n/a
Boiler and General Questions

I have recently mved into a new house with an electric boiler in floor pipiing in the beasement and radiators on the second and third floor. When I took possession, the circulator was not working properly and I repleced it with a new unit. Water is circulating fine and I have bled all air out of the system. Prolem is that the boiler never seems to get hot enough. The temp gauge will rise to 130 F and then the boiler will shut down. There are four elements inthe boiler and all LED's indicate that the elements are working correctly. The thermostat is a two wire type and is working properly. I'm wondering if this is a boiler problem (burned out elements) or perhaps the water is moving to fast to work as designed. There is a valve between the return and supply lines just above the boiler. Currently the valve is closed completely. Any thoughts?
Thanks in advance
 
  #2  
Old 10-27-05, 06:26 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 12,682
Received 41 Upvotes on 39 Posts
Electric Boiler

I hope you either have deep pockets or real cheap electric rates.
The best way to check to see if all of the elements are operating is with a clamp on amp meter. Check your control settings. They may be set at 130 for the floor loop.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: