No Heat!!!


  #1  
Old 11-25-05, 06:32 AM
Frtsprt
Visiting Guest
Posts: n/a
No Heat!!!

We have a 15 yr old Trianco oil hot water baseboard furnace. Since we first tried to start using the heat this winter, we have not had any. We have hot water but no heat. The pressure is 0. My husband is being a butthead and won't ask for help but I'm freezing today.
Thanks!
 
  #2  
Old 11-25-05, 07:47 AM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,381
Received 35 Votes on 33 Posts
No Pressure

No pressure means no heat. You need to get some pressure on the system. For a single story house 10-12 psi is fine.
 
  #3  
Old 11-26-05, 07:22 AM
Frtsprt
Visiting Guest
Posts: n/a
how?

How do we get the pressure back? We have 4 different valves.

Thanks!
 
  #4  
Old 11-26-05, 10:39 AM
H
Member
Join Date: Nov 2002
Location: Massachusetts
Posts: 1,851
Received 1 Vote on 1 Post
makeup water line

you should have a makeup water line to the boiler that might be off or the pressure regulating valve is shot. This usually has a backflow preventor attached inline with it, and the data plate will usually say that on it, it will also have an overflow tube connected to it. Before you try add water to the boiler make sure you let rest for an hour first to cool off as much as possible to prevent thermal shock of cold water to a hot boiler....
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: