The water is not circulating!!! (Hot Water Baseboard Heat)

Reply

  #1  
Old 11-10-07, 09:48 PM
T
Member
Thread Starter
Join Date: Nov 2007
Posts: 1
Received 0 Votes on 0 Posts
Angry The water is not circulating!!! (Hot Water Baseboard Heat)

Hi ALL!!!

My hot water baseboard heating system is not working... The boiler seems to work fine... the pressure is about 18psi.. temp about 190F.. it does kick on when you turn the thermostat on.
At first, i thought the system needed to be purged because i had additional baseboard put in during the summer. But i did that and STILL no luck!!! I have a TACO pump - i'm not sure how to tell if its working since it is VERY quiet!

The problem is that the hot water from the boiler does not circulate! The incoming pipe gets super hot and the outgoing one stays warm. The baseboards do NOT get warm!!!

PLEASE HELP!!!!
BBBBRRRRRRR it's cold here.

thanks
 
Sponsored Links
  #2  
Old 11-11-07, 03:56 AM
X
Member
Join Date: Nov 2005
Location: USA
Posts: 2,459
Received 0 Votes on 0 Posts
Need more info. How many zones? How much baseboard was added? Where? How much additional piping was added, if any?

There are a number of threads on here about how to purge, if you would like to check your procedure against them. Might just need another purge.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: