Priority problem with TACO SR503

Reply

  #1  
Old 12-19-07, 11:34 AM
Member
Thread Starter
Join Date: Dec 2007
Posts: 1
Priority problem with TACO SR503

I have a gas fired hot water boiler with a hot water storage tank on zone 1. There are two other zones for a total of 3 controlled by the Taco SR503 switching relay with the jumper off to provide priority to zone 1. The boiler is controlled by a Honeywell Aquastat type L8148E.

When I got up the other morning two people had had showers and the house was busy going back up to its daytime setting of 68 degrees from the night time setting of 62 degrees. The shower was cool. The hot water tank, zone 1 prioritization does not seem to be working. When I got home later the water was hot so the zone is working. It is definitely on zone 1 and the jumper has been removed. The wiring looks right. What else can I check? What might have gone wrong?
 
Sponsored Links
  #2  
Old 12-20-07, 06:46 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 13,926
Sr503

I'm not sure if there is a call for heat already in progress when the domestic calls if the priority is effective or not. You could also have a slow responding thermostat in the domestic tank. If this happens again, look at the lights on the SR503 to see if the zone 1 light is lit. If it is, how about the other lights?
 
  #3  
Old 12-20-07, 08:50 PM
Who's Avatar
Who
Who is offline
Member
Join Date: Jan 2006
Location: San Jose
Posts: 2,175
Maybe a check valve on one of the zones failed? If the DHW is taking to long top recover, go see if one of the heating zones is getting some of those BTUs instead of them all going into the DHW production.
 
  #4  
Old 12-21-07, 07:27 AM
Member
Join Date: Nov 2005
Location: USA
Posts: 2,459
My understanding is that priority means priority. If there's a space heating call in progress, it is deferred until the indirect is satisfied. For the moment, I'd go with Who on checking flow, and Grady on checking status lights, and that the problem might also be with the indirect thermostat. You might also pick up an ice-cube relay for the 503 and be prepared to swap out.
 
  #5  
Old 12-21-07, 09:17 AM
rbeck's Avatar
Member
Join Date: Jul 2007
Location: Pennsylvania
Posts: 2,438
Likes Received: 1
If the light is on for the indirect and other circ are running the control is not responding properly.
 
  #6  
Old 12-21-07, 09:21 AM
Join Date: Aug 2006
Location: usa
Posts: 902
Did the priority ever work right, or is this a new problem that just started happening?

Does the system use zone valves, or circulators?

Pete
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes