Burner Needs Reset When Hot - RIELLO 40


  #1  
Old 10-07-09, 06:15 PM
S
Member
Thread Starter
Join Date: Oct 2009
Location: New York
Posts: 1
Received 0 Votes on 0 Posts
Burner Needs Reset When Hot - RIELLO 40

Hello - I have a hydronic system, Riello 40 burner, natural gas. When initially turned on, the burner fires right up, seems to work fine. However, when the boiler water temp drops, the burner is apparently not re-lighting - I've been waking up in a cold house; at the boiler the circ pump is running, but circulating room temp water. Hitting reset causes burner to re-light normally, and all works fine again for one cycle. I checked the documentation, this burner doesn't appear to have any flashing lights or error codes. Any suggestions? Thanks in advance.
 

Last edited by NJT; 10-08-09 at 08:23 PM.
  #2  
Old 10-08-09, 08:22 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Received 4 Votes on 3 Posts
When was the last time the system was serviced?
 
  #3  
Old 10-09-09, 04:55 PM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,381
Received 35 Votes on 33 Posts
Riello 40 Gas

Riello burners can be a real bear to troubleshoot. Your problem could be one or more of many including, but not limited to: gas solenoid failing to open (why?), ignitor not arcing (why?), flame not being sensed (why?). The problem could lie in the component or the control. Unless you can catch it in the act of failing to light it's just a guessing game.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: