weil mclain tankless hot water issue


  #1  
Old 03-21-10, 04:06 PM
K
Member
Thread Starter
Join Date: Mar 2010
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
weil mclain tankless hot water issue

My hot water pressure has dropped to a dribble. I've checked the mixing valve and didn't find anything surprising. Removed the plunger & reinstalled the temp adjust cap. Nothing changed.

Wondering if the hot water heater core (insert) is clogged and if you can service any part of it. It has sweat joints, (fun) for all connections... So before I break any connections I wanted to understand if there is something else I can do first.

Or is there a way I can validate if the mixing valve is okay.
 
  #2  
Old 03-21-10, 08:18 PM
rbeck's Avatar
Member
Join Date: Jul 2007
Location: United States
Posts: 2,644
Likes: 0
Received 42 Likes on 35 Posts
The internal walls of the coil are probably blocking up. There are chemicals you can run through it to clean it but disposing of them are expensive. It is best to either eliminate the coil and go cold start boiler and an indirect water heater or to a stand alone type water heater.
 
  #3  
Old 03-25-10, 06:07 AM
K
Member
Thread Starter
Join Date: Mar 2010
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rbeck View Post
The internal walls of the coil are probably blocking up. There are chemicals you can run through it to clean it but disposing of them are expensive. It is best to either eliminate the coil and go cold start boiler and an indirect water heater or to a stand alone type water heater.
Just for grins, I disconnected the water lines and tried to blow air thru the coil using a compressor.... It held 20-25 lbs of pressure on the gage, really clogged.

I replaced the core and now have hot water (Yea!!) an a couple dribble leaks (never could sweat a joint worth an darn)..
Now I have another issue that I'll post on a new topic...

Thanks for your kind assistance.
 
  #4  
Old 03-25-10, 03:19 PM
Gerry682's Avatar
Member
Join Date: Mar 2010
Location: Philippines
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
It could be some clogged on the pipes. So check the pipe lines if they were working properly and if it still not work for you then do a research online there are good sites which will guide you in fixing and repairing problem like yours.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: