1+ yr old supervent used to work, not working now

Reply

  #1  
Old 11-19-10, 06:19 PM
Member
Thread Starter
Join Date: Apr 2007
Location: us
Posts: 67
1+ yr old supervent used to work, not working now

its been a year since i have been here and learned alot the last go round. today i have an issue with air, and the supervent in the boiler loop not purging it. its important to know this used to work just fine. supervent is on supply side of boiler, expansion tank is plumbed out the bottom of the vent. is there something that can plug these or make them not work? looks like the top can be removed . is there anything that goes wrong inside these? thanks
 
Sponsored Links
  #2  
Old 11-19-10, 07:09 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Likes Received: 1
Hey Montana, how's the mountain holding up?

Maybe you will find some help in this PDF file?

http://customer.honeywell.com/techli...0s/62-3069.pdf
 
  #3  
Old 11-19-10, 07:21 PM
Member
Thread Starter
Join Date: Apr 2007
Location: us
Posts: 67
hey thanks. i did not know about the stuff in the bottom. last time i looked up this schematic, i only remember seeing the float info. i'll take out the concentrator and see what i find.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes