Hot Surface Ignitor - issue AO Smith Unit

Reply

  #1  
Old 01-05-12, 10:36 AM
Member
Thread Starter
Join Date: Jan 2012
Location: USA
Posts: 1
Received 0 Votes on 0 Posts
Hot Surface Ignitor - issue AO Smith Unit

Heater suddenly began to malfunction over a week and it finally ceased to function. Upon reviewing A.O. Smith documentation diagnostics indicate that there is an issue with the hot surface ignitor, I took it out of boiler and for the hell of it cleaned with some steel wool and replaced, still did not work, unit looks fine to my untrained eye, before I buy a replacement unit and or bite the bullet and bring in a plumber is there anything else I could try.

Any help would be appreciated.
 
Sponsored Links
  #2  
Old 01-05-12, 04:00 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Received 2 Votes on 2 Posts
Is this a domestic water heater? or a home heating system?
 
  #3  
Old 01-05-12, 04:05 PM
lawrosa's Avatar
Super Moderator
Join Date: Dec 2010
Location: Galivants Ferry SC USA
Posts: 17,833
Received 19 Votes on 17 Posts
What is the model # and first 5 didgits of s/n?

And if intellivent gas valve whats the code?

If smart valve how many blinks?

Also you cant clean the igniter itself, but the flame sensor you can.

Once you post the model and s/n I can guide you better.

Mike NJ
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: