Smart 30 problem

Reply

  #1  
Old 04-03-12, 08:08 AM
Member
Thread Starter
Join Date: Jan 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
Smart 30 problem

I had a Smart 30 HW Heater installed about 2 years ago. It's been working fine until a couple of days ago. The water temperature changed from about 130 to 168 degrees. It is on it's own zone with a priority controller. The thermostat was set about midway (12 o' clock) to achieve the 130 degrees. I pulled the sensor out of the well and it was dry. I checked the thermostat with an ohmmeter and it does open and close (short and high resistance) as the knob is turned. The priority relay and zone relay also turn the Smart 30 circulator on and off as the thermostat knob is turned. Now I have the knob turned as low as possible and the water temperature is still 140 degrees. The water temperature of my boiler has been and still is 180. Can the thermostat still be bad? What else could cause this sudden shift in water temperature?
Thanks,
Matt
 
Sponsored Links
  #2  
Old 04-03-12, 09:25 PM
Member
Join Date: Feb 2011
Location: US
Posts: 552
Received 0 Votes on 0 Posts
Can the thermostat still be bad?
Sounds like it.


Peter
 
  #3  
Old 04-04-12, 03:18 PM
Member
Join Date: Jul 2009
Location: Toronto
Posts: 1,174
Received 0 Votes on 0 Posts
If there is ANY moisture in the area where the DHW aquastat resides, it is more than likely that the aquastat is bad.

I have had much experience with Smart tanks and leaking mix valves above putting water into the plastic top.
Always results in a rusted aquastat needing replacement.
Pull the aquastat and look at it.
 
  #4  
Old 04-05-12, 05:57 PM
Member
Thread Starter
Join Date: Jan 2010
Location: USA
Posts: 9
Received 0 Votes on 0 Posts
Hi,

Thanks for the replies. I replaced the aquastat and that wasn't the problem.
I noticed that when my heating thermostat calls for heat, the Smart 30 circulator
also turns on, but the zone 1 (HW) LED on the PCB does not light. It does light
when the Smart 30 calls for heat. I have an Argo ARM-3P controller. I checked the priority relay and it does shut off the zone 2 heat when the Smart 30 zone 1 calls for heat. I switched zone relays and it still happens.
I pulled the Smart 30 zone relay out while its circulator was running and it did shut off. It seems like the controller has a problem. When only the Smart 30 calls for heat, only the priority and zone 1 relay come on, but when zone 1 is off and zone 2 calls for heat, both zone 1 and zone 2 circulators turn on. I also switched the priority switch off, but the same problem occurred. The Smart 30 circulator is a Bell & Gossett NRF-22. The gas boiler is a 40-year old Peerless. This know that this problem just started, so I do not suspect the installation from 2 years ago. I guess that I'll be contacting Argo.

Matt
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: