steam heating system not working


  #1  
Old 11-08-12, 08:56 PM
C
Member
Thread Starter
Join Date: Apr 2006
Location: MA, USA
Posts: 88
Upvotes: 0
Received 0 Upvotes on 0 Posts
steam heating system not working

I have a steam heating system with 4 radiators on the 2nd floor. Boiler is in the basement.
I replaced a oil boiler with gas boiler.


now 1 of the radiators is not working properly. Sometimes it works and sometime it does not. Sometimes water come out of the radiator. Boiler water level swinging up and down a lot when it starts. Boiler controller blinking red light when it stop working. I don't see automatic water feeder anywhere.
 
  #2  
Old 11-08-12, 09:02 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Jersey
Posts: 71,641
Received 3,324 Upvotes on 2,985 Posts
A make and model of boiler would be a big help to start as would several pictures of your plumbing around the new boiler.
 
  #3  
Old 11-09-12, 10:17 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,538
Upvotes: 0
Received 8 Upvotes on 6 Posts
Was the boiler properly 'skimmed' after installation?

You need to buy and read this book:

Heating Help

Written in layman's terms, very understandable and FUN to read.

How long ago was the boiler installed? You should probably call back the installer.
 
  #4  
Old 11-10-12, 12:39 AM
F
Member
Join Date: Mar 2006
Location: Wet side of Washington state.
Posts: 18,495
Received 37 Upvotes on 29 Posts
Lay a carpenter's level on the top of the non-heating radiator. It should be very slightly tipped so that the steam inlet valve end is lower than the air vent end. You MUST always have the valve either fully open or fully shut. Does the air vent work?
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: