CGI Boiler

Reply

  #1  
Old 12-29-12, 10:17 AM
J
Member
Thread Starter
Join Date: Dec 2012
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
CGI Boiler

Boiler goes though all its cycles an gas valve fires. Stays lit 4 appox. 30 seconds than shuts down, keeps repeating. CGI boiler
 
Sponsored Links
  #2  
Old 12-29-12, 12:49 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Received 3 Votes on 2 Posts
Today seems to be the day for flame rod problems...

Does the main burner light? or only the pilot?
 
  #3  
Old 12-29-12, 03:18 PM
J
Member
Thread Starter
Join Date: Dec 2012
Location: usa
Posts: 2
Received 0 Votes on 0 Posts
main burner lights 4 30sec. than goes out an keeps repesting
 
  #4  
Old 12-29-12, 05:04 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Received 3 Votes on 2 Posts
Is your boiler a "Series 1" ?

If so, and you don't have the manual, here it is:

http://www.weil-mclain.com/en/multim.../cgi_ser_1.pdf

You may have a problem with the pressure switch and/or the blower, or the 'flame rod', and/or the ignition control.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: