boiler not circulating

Reply

  #1  
Old 01-06-14, 06:06 AM
Member
Thread Starter
Join Date: Jan 2014
Location: U.S.
Posts: 3
boiler not circulating

Good morning- I have a Dunkirk boiler controlled by a Honeywell Aquastat relay. The problem is the circulating pump is not activating during boiler run. Did some preliminary testing and believe re-circulator switch is shot. Have since bypassed switch and wired pump to a plugin cord that is used when boiler fires up.
Does this sound right? any input? I have done some research, seems likely I have to replace Aquastat relay. Relay #L8148A. No. on back 2146
 
Sponsored Links
  #2  
Old 01-06-14, 06:53 AM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,539
Likes Received: 1
You are saying that the pump was originally wired to the C1 and C2 terminals in the L8148 aquastat and when there was a call for heat, there was no voltage delivered to C1/C2, and the pump did not run.

You connected a 120VAC source to the pump and proved that the pump runs properly...

Yes, it would seem that the aquastat is at fault.

Are you capable of soldering electronic circuit boards? I'm willing to bet that if you were to disassemble that aquastat you would find cracked solder connections at the relay pins...
 
  #3  
Old 01-06-14, 07:08 AM
Member
Thread Starter
Join Date: Jan 2014
Location: U.S.
Posts: 3
Thank you NJ Trooper, unfortunately I'm not equipped for that.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes