hot water does not work well for Baxi Luner 310 fi combi boiler

Reply

  #1  
Old 03-24-14, 10:46 AM
Member
Thread Starter
Join Date: Dec 2011
Location: us
Posts: 4
Received 0 Votes on 0 Posts
hot water does not work well for Baxi Luner 310 fi combi boiler

Having the boiler for a few years. It worked well in the past for both heating and hot water. It normally switches to hot water immediately when the hot water tap is open in the kitchen sink or turn on shower. But now it only works on when you turn shower. It does not response when turn on hot water tap.
The heating is still work fine.
Any one has an idea what could be the cause? Thanks.
 
Sponsored Links
  #2  
Old 03-24-14, 10:49 AM
Member
Thread Starter
Join Date: Dec 2011
Location: us
Posts: 4
Received 0 Votes on 0 Posts
When there is CH (heating) request, it will continue on CH mode when you turn on hot water tap, and the water is hot. IF i switch DHW mode, and open the hot water tap, it will not fire up, and water is cold. the volume of water from hot water tap is normal.
 
  #3  
Old 03-24-14, 05:26 PM
poorplmbr's Avatar
Member
Join Date: Feb 2003
Location: long island ,new york
Posts: 296
Received 0 Votes on 0 Posts
Sounds like the filter/turbine needs to be replaced..take the cover off the unit and run the hot water..look behind and to the left of the internal circulator pump..you will see a red LED, if it is blinking when the water is running rather than a solid light, the turbine is scaled and calcified..you might be able to cure the problem by power flushing the domestic water side of the unit with white vinegar, but i usually replace the part...
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: