Amtrol boilermate problem


  #1  
Old 02-14-15, 11:10 AM
J
Member
Thread Starter
Join Date: Feb 2015
Location: USA
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Amtrol boilermate problem

I have a 41 gallon WH 7L 7P boilermate. The temperature control has strted making a clicking sound. The control doesn't have individual buttons to raise or lower the temperature. It has one spot to push that adjusts temperature. I'm assuming when pushed it is supposed to cycle through to the max. and then go back to the lowest setting. Mine is now clicking and the power indicator flashes simultaneously . This happens probably every two seconds. When I try resetting the temperature it goes up one or so degrees and then stops. It is now up to 130 degrees and I can't get it to move off of that. Does this sound like a bad control. I figured before buying a new one I'd try to be sure this is the problem.
I want to point out I also have a tarm multi fuel furnace which this time of the year I fire with wood on a regular basis. Could fluctuations in the water temperature have anything to do with this?

Thanks,
John
 
  #2  
Old 02-14-15, 01:22 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,538
Likes: 0
Received 8 Likes on 6 Posts
I can't recall the details, but there was some 'issue' with those electronic controls a while back.

How old is your unit?

No, I don't think there's any way that running the Tarm is going to hurt that control...
 
  #3  
Old 02-14-15, 01:52 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,538
Likes: 0
Received 8 Likes on 6 Posts
They have both mechanical and electronic thermostats for your model.

Here is the mechanical one I believe will fit your unit (VERIFY BEFORE PURCHASING!!)

2704-093 - Amtrol 2704-093 - Aquastat/Thermostat

Parts list says that this is the digital control... (VERIFY BEFORE PURCHASING!!)

940R101 - Amtrol 940R101 - SmartControl w/ Thermistor
 
  #4  
Old 02-17-15, 08:51 PM
S
Member
Join Date: Dec 2010
Location: USA
Posts: 183
Likes: 0
Received 0 Likes on 0 Posts
They had a bad batch of those controllers I think. I went through 2 under warranty and when the third went I switched to the mechanical one and have had 10 Years of no issues.
 
  #5  
Old 02-17-15, 09:02 PM
NJT's Avatar
NJT
NJT is offline
Member
Join Date: Oct 2006
Location: USA
Posts: 23,538
Likes: 0
Received 8 Likes on 6 Posts
Did you need to change the panel it mounts on? Parts lists show two different panels. Or, were you able to mount the mechanical on the old panel?
 
  #6  
Old 02-18-15, 04:41 PM
S
Member
Join Date: Dec 2010
Location: USA
Posts: 183
Likes: 0
Received 0 Likes on 0 Posts
The one I got came with a new panel. The old panel still sits behind the tank.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: