Burnham ES24 appears no power

Reply

  #1  
Old 09-04-16, 12:58 PM
Member
Thread Starter
Join Date: May 2016
Posts: 5
Burnham ES24 appears no power

Our (March 2015 newly installed) Burnham ES24 appears not to be powering up at all and I'm trying to narrow down if there's an electrical problem to the unit or a failure on the Intelligent Hydronic Control board (or IQ board even though we have no option cards).

We haven't used this in a couple of months and I just went to turn it on and it appears as if there is no power to the unit - no LEDs lighting up, no indication of power at all.

I've double checked the fuse box and visually inspected the short distance to the unit and it looks like everything should have power fine to the unit itself. A voltage tester confirms power at the disconnect switch located at the boiler. Everything is on.

Is it typical that if one of the boards failed my symptoms would be similar? Is there any other place in particular I should check voltage to help narrow down the problem?

And would you guess this would most likely be a Control Board failure as opposed to the IQ board? My Control Board shows part "103660-01" and below the bar code it reads "50045578-003 Rev B"

thanks
 
Sponsored Links
  #2  
Old 09-04-16, 01:47 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 50,571
Likes Received: 108
Welcome to the forums.

Do you have a voltmeter or voltage tester ? Not a non contact test pen.

You'll need to check for 120VAC on L1 and L2 at P1 on the control board.
If that is present you'll need to check for 24VAC on P4 on the control board.

Name:  zz.jpg
Views: 233
Size:  40.8 KB
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes