Diy boiler repair help

Reply

  #1  
Old 10-02-17, 06:19 AM
A
Member
Thread Starter
Join Date: Oct 2017
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Diy boiler repair help

Having problems with moniitron slant fin boiler,heating contacts not coming in, i think it may be the seqencer, I'm not an electrician, when I try to order a new one I'm asked if the seqencer is for a 1 switch or for a 2 switch, how do I know? Help would be greatly appreciated.
 
Sponsored Links
  #2  
Old 10-02-17, 09:52 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,069
Received 1,109 Votes on 1,029 Posts
Welcome to the forums.

You're not an electrician and we aren't mind readers.
We can't see what you have there.

A full model number would be a big help.
Pictures are also helpful. http://www.doityourself.com/forum/el...-pictures.html
 
  #3  
Old 10-03-17, 03:44 AM
A
Member
Thread Starter
Join Date: Oct 2017
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Sorry for that, I'm new. Model EH-12-135-S
 
Attached Images  
  #4  
Old 10-03-17, 11:09 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,069
Received 1,109 Votes on 1,029 Posts
Ok... you posted a generic picture from the manual. In order for me to help you I need pictures of your actual unit. For some reason Slant Fin has chosen not to publish any wiring diagrams for the electric boilers.

The sequencer is just one part that may be bad. You have a control transformer, aquastat, high heat limit switches that can also cause a no heat problem.

Your boiler should have a wiring diagram on it. I need that posted here in a 600x600 up to 900x900format so that it's readable. You are going to need a meter too.

Installation.... Monitron-Installation-and-Operating_117.pdf
Spec sheet... including your picture.... Monitron-Catalog-Sheet-710.pdf
Parts..... Monitron-Parts-List_617.pdf
 
  #5  
Old 10-04-17, 04:52 AM
A
Member
Thread Starter
Join Date: Oct 2017
Location: USA
Posts: 3
Received 0 Votes on 0 Posts
Hi Pete, I have it figured out, it was the flo switch, i thank you for taking the time to help me
 
  #6  
Old 10-04-17, 05:03 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 59,069
Received 1,109 Votes on 1,029 Posts
You're welcome. Good job.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: