Problem with boiler controls

Reply

  #1  
Old 06-30-18, 03:14 PM
Member
Thread Starter
Join Date: Jun 2018
Posts: 3
Received 0 Votes on 0 Posts
Problem with boiler controls

Hi everyone,

I have been having a problem with the hot water recirculator pump on my boiler.

The system has three grundfos recirculating pumps. One goes to the hot water tank, one goes to the first floor, and one goes to the second floor baseboards. This summer I have noticed that every time the system calls for hot water, both the hot water pump and the first floor baseboard pump turn on.

Obviously this is sending hot hot water through the first floor baseboards when its air conditioning season. When I turn on the first floor thermostat, only the first floor pump goes on, same for the second floor. But again when the hot water thermostat is turned up both The hot water and the first floor pump come on.

All the the pumps are powered by a Argo 3p relay box with the priority switch set to on... the hot water pump is wired to the “priority” area on the board.

Does anyone know what is going on here?? Thanks
 
Sponsored Links
  #2  
Old 06-30-18, 03:26 PM
rbeck's Avatar
Member
Join Date: Jul 2007
Location: Pennsylvania
Posts: 2,449
Received 1 Vote on 1 Post
Which boiler do you have? It is unusual that the IWH is wired to the zone panel. That may be causing the pump to run depending on settings.
 
  #3  
Old 06-30-18, 03:32 PM
Member
Thread Starter
Join Date: Jun 2018
Posts: 3
Received 0 Votes on 0 Posts
It is a Burnham boiler, the hot water heater recirculator is zone 1, floor 1 is zone 2, and floor 2 is zone 3
 
  #4  
Old 07-01-18, 05:47 PM
rbeck's Avatar
Member
Join Date: Jul 2007
Location: Pennsylvania
Posts: 2,449
Received 1 Vote on 1 Post
What is the boiler model #? High-efficiency gas, cast iron gas or oil.
 
  #5  
Old 07-02-18, 06:54 PM
Member
Thread Starter
Join Date: Jun 2018
Posts: 3
Received 0 Votes on 0 Posts
Not sure of the boiler model #, it is an oil fired boiler... however the problem is not with the boiler itself rather the circulating pump for the first floor seems to be coming on Anytime the pump for the hot water tank comes on.
 
  #6  
Old 07-07-18, 03:56 AM
poorplmbr's Avatar
Member
Join Date: Feb 2003
Location: long island ,new york
Posts: 297
Received 0 Votes on 0 Posts
Boiler control

Bad Argo control, see this same issue all the time with old Argo ARM controls. Swith it out for a new Taco SR503 w/ priority.
 
  #7  
Old 07-08-18, 04:56 AM
Geochurchi's Avatar
Member
Join Date: Nov 2012
Location: USA
Posts: 3,982
Received 16 Votes on 16 Posts
Hi, is this something that just started happening?
Geo
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: