15-58 fc pump failure


  #1  
Old 01-05-20, 06:06 AM
W
Member
Thread Starter
Join Date: Jan 2020
Posts: 1
Received 0 Votes on 0 Posts
15-58 fc pump failure

I have a 15-58 fc pump. It got hot and stopped circulating water. I manually increased the water pressure and the pump began working it shortly failed again. I replaced with a new pump after about 2 weeks the same problem occurred., the pump is hot to touch and not circulating water.
 
  #2  
Old 01-05-20, 07:26 AM
Grady's Avatar
Forum Topic Moderator
Join Date: Jan 2005
Location: Delaware, The First State
Posts: 14,381
Received 35 Votes on 33 Posts
How much pressure is on the system? Is it possible there is air in the system preventing the pump from getting water? Pictures might help.
https://www.doityourself.com/forum/e...-pictures.html
 

Last edited by Grady; 01-05-20 at 07:33 AM. Reason: Added picture link
  #3  
Old 01-05-20, 07:34 AM
P
Member
Join Date: Feb 2019
Location: United States
Posts: 199
Received 3 Votes on 3 Posts
Not sure if this could cause it but maybe a zone valve downstream isnt opening? I had one of my taco 3 wire zone valves' motors rotate slightly and disengage from the valve in the pipe. So on call for heat, valve motor head would energize, end switch would close and fire boiler/turn on circ but motor was detached and never opened the valve. I can't imagine my circulator was happy; just glad I was home and caught it. Not sure if this is a likely scenario for your symptoms; just a thought.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: