Taco ZVC403 Zone Valve Control not powering up

Reply

  #1  
Old 06-29-20, 01:20 PM
R
Member
Thread Starter
Join Date: Jun 2020
Posts: 1
Received 0 Votes on 0 Posts
Taco ZVC403 Zone Valve Control not powering up

I am installing a new Taco ZVC403 Zone Valve Control unity and initially it powered up fine and worked with my old thermostats. Then I started adding new Honeywell Thermostats, two T6's and one VisionPro 8000. The T6's worked fine, but the 8000 wasn't engaging the unit.

The Taco is connected to an oil burner/pump system for radiant flooring.

After transferring the black wire from the C terminal to the W terminal on the 8000, (it is only a two wire hookup because there is no fan) because the C terminal didn't seem to work, I checked the 8000 LED lights and nothing was on, not even the green power on light. I checked the inline 5amp fuse and it was fine. But there appears not to be an power to the board itself. There is 120V to the transformer....


Any ideas? Did I blow the 24V transformer with my hooking up the black wire to the W slot instead of the C slot on the Honeywell 8000? It is a mystery to me.

BTW, the Honeywell T6s are hooked up to the W slot with the black wire, and the red wire to the red slot.

Any help would be appreciated.
 
Sponsored Links
  #2  
Old 06-29-20, 01:31 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 57,102
Received 840 Votes on 787 Posts
Welcome to the forums.

I moved your thread to the boiler forum.
The visionpro stat runs better on three wires to operate.
An R, W and C.

Actually.... the T6's require a C wire too. Three wires.

Post a picture of the Taco control.... How-to-insert-pictures.
 

Last edited by PJmax; 06-30-20 at 09:18 AM.
  #3  
Old 06-30-20, 08:05 AM
Geochurchi's Avatar
Member
Join Date: Nov 2012
Location: USA
Posts: 4,505
Received 42 Votes on 40 Posts
Hi, if you have only 2 wires at the 8000 use R&W , have you installed batteries? T 6 will operate with 2 wires as long as batteries are installed C wire is optional.
as Pete stated post some pics.
Geo
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: