Num Lock


  #1  
Old 03-15-04, 05:59 PM
S
Member
Thread Starter
Join Date: Jul 2003
Location: kansas city MO
Posts: 103
Received 0 Votes on 0 Posts
Num Lock

I know this is really, really basic stuff, but I haven't done it since DOS days with batch files, and I've slept since then. How do I set my start menu to toggle on the Num Lock at startup?
 
  #2  
Old 03-15-04, 06:50 PM
C
Member
Join Date: Nov 2001
Location: Taylors, SC
Posts: 9,483
Received 0 Votes on 0 Posts
What operating system?
 
  #3  
Old 03-15-04, 07:02 PM
tae's Avatar
tae
tae is offline
Member
Join Date: Nov 2002
Posts: 2,467
Received 0 Votes on 0 Posts
Make sure it is enabled in your bios. Then:
Here's the registry key to enable numlock at startup:
HKEY_Current_User\ControlPanel\Keyboard\InitialKeyboardIndicators

Type REG_SZ:

If set to 0, NumLock is disabled for that current user after logging on. If it is 2, NumLock is enabled and will retain the settings from the last shutdown.
 
  #4  
Old 03-16-04, 07:47 AM
S
Member
Thread Starter
Join Date: Jul 2003
Location: kansas city MO
Posts: 103
Received 0 Votes on 0 Posts
Originally posted by chfite
What operating system?
Sorry. It's Windows 2000.
 
  #5  
Old 03-16-04, 09:02 AM
S
Member
Thread Starter
Join Date: Jul 2003
Location: kansas city MO
Posts: 103
Received 0 Votes on 0 Posts
Originally posted by tae
Make sure it is enabled in your bios. Then:
Here's the registry key to enable numlock at startup:
HKEY_Current_User\ControlPanel\Keyboard\InitialKeyboardIndicators

Type REG_SZ:

If set to 0, NumLock is disabled for that current user after logging on. If it is 2, NumLock is enabled and will retain the settings from the last shutdown.
It (bios) must be enabled, because my screen comes up that way. Can't remember how I did it. My wife's screen comes up unlocked, which frustrates her, which frustrates me.

Anyway, how do I get to the "HKEY_Current_User..."?
 
  #6  
Old 03-16-04, 04:01 PM
tae's Avatar
tae
tae is offline
Member
Join Date: Nov 2002
Posts: 2,467
Received 0 Votes on 0 Posts
Start button, click run, type "regedit" in the box.

Or:
Even if your motherboard BIOS Setup doesn't support/include an option to turn on/off the annoying NumLock key upon (re)boot, you can still do this by hacking your Windows NT4/2000/XP/2003 Registry.
Start by copying & pasting the lines below into a blank Notepad window, then save this file as NLOCKON.REG and finally (double)-click on it from Windows Explorer to turn ON NumLock:
-----Begin cut & paste here-----
REGEDIT4

[HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
"InitialKeyboardIndicators"="2"

------End cut & paste here------

To turn NumLock back OFF, replace the "InitialKeyboardIndicators" value of 2 with 0, save the file as NLOCKON.REG and run it.
 
  #7  
Old 03-16-04, 04:29 PM
S
Member
Thread Starter
Join Date: Jul 2003
Location: kansas city MO
Posts: 103
Received 0 Votes on 0 Posts
Thanks. It was already set to "2," and as I was logging off her site, I noticed that her num lock was on. Maybe she's hitting it accidentally, or maybe something strange is happening. I'm calling it fixed, and ta dah - it's no longer a problem.

Thanks again.
 
  #8  
Old 03-16-04, 07:49 PM
tae's Avatar
tae
tae is offline
Member
Join Date: Nov 2002
Posts: 2,467
Received 0 Votes on 0 Posts
LOL! One way or another, eh?
Glad it's working.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: