slow wireless n network


  #1  
Old 01-12-12, 07:57 AM
J
Member
Thread Starter
Join Date: Apr 2004
Location: USA
Posts: 361
Upvotes: 0
Received 0 Upvotes on 0 Posts
slow wireless n network

I have three computers (1 XP with g adapter, 1 Vista with n adapter, and 1 Win 7 with n adapter) connected through a D-Link 615 wireless router connected to a Linksys ethernet router connected to a Seiman's speedstream 4100 DSL modem. (Kind of sounds link a child's song). All computers are connected by both wireless and ethernet cable. There is also an Ipad and an Iphone 3gs in the wireless network. When I remove the ethernet cable from the Win 7 machine and check the status of the wireless connection, it shows excellent, but a speed of about 30 Mbs. The XP with g shows 54 Mbs with weak connectivity. I thought the n's were supposed to be 150 Mbs. I have the D-Link set to "both g and n adapters" and auto 20/40. How do I get the n's up to speed? Also, how does an individual computer decide which connection to use - ethernet or wireless?
 
  #2  
Old 01-12-12, 03:37 PM
R
Member
Join Date: Apr 2007
Location: Near Buffalo, NY
Posts: 4,070
Upvotes: 0
Received 1 Upvote on 1 Post
Those numbers are decent for a home network. Are you experiencing dropouts?
 
  #3  
Old 01-12-12, 06:08 PM
J
Member
Thread Starter
Join Date: Apr 2004
Location: USA
Posts: 361
Upvotes: 0
Received 0 Upvotes on 0 Posts
It's funny you should ask. The connection has been fine for more than a week. Just now, the wireless dropped the internet and I can't find out why. I have turned off the whole system and repowered it. The network strength is excellent, but it is local only. I was getting network over the IPv4 connnectivity side and not the IPv6. Now, there isn't any. The ethernet side is working fine at 100 Mbs. The wireless has 150 Mbs for local.
 
  #4  
Old 01-13-12, 10:52 PM
Spikester's Avatar
Member
Join Date: Jun 2011
Location: USA
Posts: 167
Upvotes: 0
Received 0 Upvotes on 0 Posts
Not sure exactly what the issue is because I am tired and didn't quite understand what the issue is. However for the speed difference, when it is set in g/n mode it will only function at g rates. It can only run as fast as the slowest device. Also wireless is shared among all devices. Therefore even if you had 150mb it would be distributed among all wireless devices connected to it. Also each ethernet link is 100mb (unless gigabit) and each one is itself a dedicated line. Next with having both cabled and wireless you should choose one or the other. Using both can cause issues with Windows. It should choose the faster of the two connections, but it will likely try connecting with both and having collision issues. For your n devices set your router to n only and you will see your speeds, but the g devices will not be able to connect.

Hope this helps
~Spike
 
  #5  
Old 01-14-12, 09:52 AM
J
Member
Thread Starter
Join Date: Apr 2004
Location: USA
Posts: 361
Upvotes: 0
Received 0 Upvotes on 0 Posts
Thanks for your comments and suggestions. I have set the D-Link wireless router to use only n adapters and set the computers to use either the wireless or the ethernet, but not both. When I check the status of the wireless adapter on one of the computers it now shows to be operating at the 150 Mbs and access to the internet is much faster. Also, the Ipad seems to be running faster.

However, when I open the network and sharing center, it shows 2 wireless networks that appear to be identical except that one is called "Name" and the other is called "Name 2". Can you tell me what is happening? If I disconnect either one, the other is also disconnected. Their status is identical with both operating at 150 Mbs.
 
  #6  
Old 01-14-12, 09:51 PM
Spikester's Avatar
Member
Join Date: Jun 2011
Location: USA
Posts: 167
Upvotes: 0
Received 0 Upvotes on 0 Posts
I'm guessing this is a dual band router. Which means it is using both 5.8 GHZ band and 2.4 GHZ. You should be able to change the settings in the router to choose one or the other. Really it shouldn't cause any issues because it is the same network. Which is why when you disconnect one you disconnect both. If you have cordless phones that run on 2.4 or 5.8 consider disabling that frequency in your router so that it does not cause interference issues. (E.G. If your cordless phones run on 5.8 GHZ then disable 5.8 GHZ in your router and just run off the 2.4 GHZ band. This will also make it so you only see one network.)

Hope this helps.
~Spike
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: