Epson NX420

Reply

  #1  
Old 06-19-17, 04:41 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,173
Received 25 Votes on 24 Posts
Epson NX420

Hi All, nothing but problems with this printer recently, now it won't make copies, only about the size of a post card, even when the setting is at 100% or in auto, any thought?
Geo
 
Sponsored Links
  #2  
Old 06-19-17, 05:24 PM
Banned. Rule And/Or Policy Violation
Join Date: Jun 2017
Location: USA
Posts: 785
Received 0 Votes on 0 Posts
When did the problems start? Since you said recently, I presume that the printer worked for awhile.
 
  #3  
Old 06-20-17, 04:52 AM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,173
Received 25 Votes on 24 Posts
Hi, printer has worked fine, in fact the printer works from my computer, just won't make a copy
 
  #4  
Old 06-20-17, 06:51 AM
Banned. Rule And/Or Policy Violation
Join Date: Jun 2017
Location: USA
Posts: 785
Received 0 Votes on 0 Posts
Are you getting an error message on the printer screen?
 
  #5  
Old 06-20-17, 06:15 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,173
Received 25 Votes on 24 Posts
Hi, problem solved,I finally got ahold of Epson TS and after doing a restore to factory default, all is well.
 
  #6  
Old 06-20-17, 06:21 PM
Banned. Rule And/Or Policy Violation
Join Date: Jun 2017
Location: USA
Posts: 785
Received 0 Votes on 0 Posts
Glad to hear it!
____________
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: