Wifi not working on windows 10

Reply

  #1  
Old 09-05-17, 01:27 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
Wifi not working on windows 10

I have a Toshiba Satellite with Windows 10.
Wifi was working perfect . A few days back, I connected to wifi using my phone as a wifi hub . since then, Wifi stopped working. After a Driver upgrade , it is working intermittently -- connects sometimes and then disconnect after a few minutes/hours.
I have tried DNS flush , driver update uninstall/reinstall everything. I am a Software engineer , so can do basic troubleshooting but at this point , I am just out of ideas.

Can someone suggest any other step ?
 
Sponsored Links
  #2  
Old 09-05-17, 02:04 PM
H
Member
Join Date: Nov 2012
Location: USA
Posts: 1,537
Received 69 Votes on 60 Posts
I've had something similar, solution was to login as admin, hook the phone BACK UP,
THEN uninstall ALL of the phone/android/sdk drivers,
Then uninstall the WIFI drivers.
Then, boot up so that the computer loads the wifi drivers without any phone drivers in the system.
 
  #3  
Old 09-05-17, 02:13 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
Thanks but I did not get what is Phone/Android Driver ? I used the phone as a wifi (Tethering) and connected the laptop using Wifi . Is there a separate driver for phone ? I know I have one for LAN and one for Bluetooth
 
  #4  
Old 09-05-17, 02:22 PM
H
Member
Join Date: Nov 2012
Location: USA
Posts: 1,537
Received 69 Votes on 60 Posts
WEll, usually, the phone-tethering via android (cellular data or wifi) will load a driver for the phone,
and it will create a new "network" connection for the phone.

Either or those can mess up the existing, ethernet.
 
  #5  
Old 09-05-17, 02:26 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
Got it. Let me see if I can find it. I tethered through iPhone though (not android) but you are right, I too suspect something somewhere got created which is causing the conflict
 
  #6  
Old 09-05-17, 02:43 PM
D
Banned. Rule And/Or Policy Violation
Join Date: Sep 2017
Location: USA
Posts: 517
Received 0 Votes on 0 Posts
Are there any problems if you connect the laptop to the router instead of the phone?
 
  #7  
Old 09-05-17, 05:03 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
Originally Posted by Donato_ View Post
Are there any problems if you connect the laptop to the router instead of the phone?
Yes, connecting to ANY wifi is a problem now. BTW, another point is I have two wifi -- The Verizon FIOS (router+wifi) and a Netgear N300. The Netgear is connected to Verizon. I connected that way because signal from FIOS is poor in upper level ... so connected the Netgear at upper level. Thinking I should switch off Netgear and see if it improves
 
  #8  
Old 09-05-17, 05:30 PM
D
Banned. Rule And/Or Policy Violation
Join Date: Sep 2017
Location: USA
Posts: 517
Received 0 Votes on 0 Posts
It's not a good idea to use 2 routers on the same Class C network. The only way that can work is if you disable the DHCP server on one of them & use it as a switch. You really don't have 2 ISPs. It's all Verizon FIOS. If you have either router on the floor, put it on a table. Disconnect the Netgear for now. Connect the PC to the Actiontec or Qualcom, whichever Verizon supplied. Move the Toshiba to the same floor. See how the connection is. Then move it back to where you like it. Where is the PC & where is the Verizon router normally?
 
  #9  
Old 09-05-17, 05:42 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
Let me try that out. The router is in lower level and laptop on upper level . signal is not too bad in all rooms in upper level -- just 2 rooms. Will avoid those rooms for now if this works
 
  #10  
Old 09-05-17, 05:47 PM
D
Banned. Rule And/Or Policy Violation
Join Date: Sep 2017
Location: USA
Posts: 517
Received 0 Votes on 0 Posts
See how that goes. If there is still a problem, you can buy a USB wireless adapter. It might work better than the internal adapter in the laptop.
 
  #11  
Old 09-07-17, 08:00 PM
K
Member
Thread Starter
Join Date: Jul 2014
Posts: 157
Received 3 Votes on 3 Posts
I am back. After I turned off the second router, it connected to the primary router (Verizon) for a while but dropped after a few hours. When I tried after that, it is either not connecting or connecting and randomly dropping. When it connects , it is super slow.

I have some info about the Adapter. Can anybody find anything from this --

SSID: FiOS-TLIUY
Protocol: 802.11n
Security type: WPA2-Personal
Network band: 2.4 GHz
Network channel: 1
IPv4 address: 192.168.1.168
Manufacturer: Broadcom
Description: Broadcom 802.11n Network Adapter #2
Driver version: 7.35.333.0
Physical address (MAC): ‎30-52-CA-AF-F0-17
 
  #12  
Old 09-08-17, 04:47 AM
D
Banned. Rule And/Or Policy Violation
Join Date: Sep 2017
Location: USA
Posts: 517
Received 0 Votes on 0 Posts
Some people aren't fans of Broadcom. Before you buy a USB adapter, try to change the channel. Is the channel set to 1 or automatic? The web interface should be 192.168.1.1
 
  #13  
Old 09-10-17, 01:27 PM
F
Member
Join Date: May 2010
Location: USA
Posts: 462
Received 19 Votes on 15 Posts
Try uninstalling the device in Device Manager, turn the PC off, remove the battery for a few seconds, reinstall the battery and then reboot. Uninstalling through Device Manager doesn't do anything destructive or irreversible, it just disassociates the drivers from the device. It's a Gordian knot solution and I do this a lot when I come across a problem related to the "It's a Windows thang" syndrome.

When the OS loads and finds a device installed that has no drivers associated with it, Windows by default will reinstall them. You get a fresh copy of the drivers and for good measure it should break whatever relationship the tethering had with the WiFi NIC.

To open Device Manager, if you know where the"My PC" or "My Computer" icon is in your Start menu, navigate to it, right-click on it and select "Manage"

If you can't find it in your start menu, open a command line (DOS window) or hit <Windows key><R> and enter "mmc devmgmt.msc" (without the quotes). I'll put it on a line by its lonesome to make it easier to cut-n-paste:

mmc devmgmt.msc

When the Computer Management applet opens, in the left-hand pane, select "Device Manager." Next, in the right-hand pane, click on the caret (>) next to "Network adapters". The entries for all your NICs will spill out beneath. Right-click on the device you want to uninstall (in my case, it was a Broadcom 802.11N NIC), then left-click on "Uninstall device."

It should look something like this:



Then reboot IMMEDIATELY, else Windows will try to reinstall it on the fly. And you'd prefer it waits until after you've cleared the registers before it does that, which is the point of powering it off and removing the battery before rebooting.

Chances are, it wll reinstall the device without so much as displaying a notification, using the existing driver. I just now tested it on my Win10 PC (the one I'm writing this from) and there was no indication anything was going on, but the "Broadcom 802.11N" setting had returned to Device Manager. Older versions of Windows used to prompt for user input, but I've not seen Win10 do that. And obviously the NIC is still working, otherwise you wouldn't be reading this.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: