Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Windows 98 Autorun


's Avatar
Visiting Guest

Posts: n/a

05-31-01, 12:28 PM   #1  
I am running Windows 98 on a Hewlett-Packard PC. Commercial software CD-ROMS that used to automatically start up when inserted into my CD drive no longer do. However, they will start and run just fine if I double click on the .exe or .bat files when I pull up the files listing for the CD-ROM.

Oddly (to me) enough, MUSIC CD's will bring up my CD Player utility and will begin to play music automatically as soon as I load the music CD into my CD drive.

I have seen tips on how to turn OFF autorun but I want to turn it back ON. I have gone into the properties settings for my CD drive under Device Manager and "Auto Insert Notification" IS turned ON.

Can somebody please help me (or, actually, help my young kids because they're the ones who need this autorun feature) get autorun reactivated? And why do music CD's "autorun" but not software CD's?

 
Sponsored Links
dkerr's Avatar
Member

Join Date: Sep 2000
Posts: 1,165
CANADA

05-31-01, 01:36 PM   #2  
try this, turn auto insertion off, reboot the computer.
Now turn auto insertion back on, reboot the computer.

Check if it works now, repost.

 
's Avatar
Visiting Guest

Posts: n/a

05-31-01, 10:49 PM   #3  
Thanks for the suggestion. Unfortunately, I tried it and still have the same problem. -- Robert

 
's Avatar
Visiting Guest

Posts: n/a

06-01-01, 11:07 PM   #5  
Dkerr,

Thanks for your help. It's working now. For anyone else reading this with the same problem, here's what I did:

1. Go to Start/Run.
2. Type REGEDIT and click OK to open.
3. Drill down the following path:
HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ Explorer
4. Right click on NoDriveTypeAutoRun and select Modify.
5. Change the value of the NoDriveTypeAutoRun key to 0000 95 00 00 00 and click OK.
6. Quit the Registry Editor.
7. Restart Windows for your change to take effect.

 
Search this Thread