Frequent Wireless Disconnect

Reply

  #1  
Old 09-12-19, 10:31 AM
Member
Thread Starter
Join Date: Mar 2008
Location: Boulder, CO
Posts: 1,074
Received 2 Votes on 2 Posts
Frequent Wireless Disconnect

For some time now my laptop (2012 Lenovo) farthest from the modem will frequently disconnect from my wireless home network (Comcast). I have to then click disconnect and connect and it comes right back. This morning I installed a new modem and the problem is worse, with it disconnecting every few minutes. The reason for the new modem was higher speed. Comcast claims up to a gig. I am actually getting under 50 megs. Any ideas out there?
 
Sponsored Links
  #2  
Old 09-12-19, 12:24 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 21,061
Received 239 Votes on 218 Posts
Which modem did you replace? The one in the computer or the wifi router? If you are using the provided modem/wireless wifi from Comcast they are not the best. Use their box for handling the modem portion but get a separate, good quality wifi router.

Higher speed often results in shorter range as it can be using a higher frequency that has shorter range. Also you simply cannot shove more data through a weak connection. That's why wireless speeds drop with signal strength.
 
  #3  
Old 09-12-19, 01:48 PM
Member
Thread Starter
Join Date: Mar 2008
Location: Boulder, CO
Posts: 1,074
Received 2 Votes on 2 Posts
Thanks Pilot

I replaced the Comcast Modem/Router. I know this forum is not Consumer Reports, but can you recommend a good wi-fi router? I am very technically challenged.
 
  #4  
Old 09-13-19, 06:36 AM
Davejb's Avatar
Member
Join Date: May 2002
Location: USA
Posts: 810
Received 0 Votes on 0 Posts
How are you doing your speed tests? You need to use ethernet from the gateway to your laptop for accurate results and the laptop has to have a GB ethernet adapter. If your testing while connected to the 2.4 wifi band you going to get the results you saw, the 5G should be better but you still likely won't see a gig.
 
  #5  
Old 10-18-19, 08:41 AM
Member
Thread Starter
Join Date: Mar 2008
Location: Boulder, CO
Posts: 1,074
Received 2 Votes on 2 Posts
I replaced the old Lenovo with an HP Chromebook. Ookla speed test says I am running in excess of 250 megs on 5G. However, the disconnect problem persists on this laptop which is on the 2nd floor and the Comcast modem/router in on the first. At least the Chromebook gives me a message when internet is lost and it reconnects automatically in a minute or two. Any suggestions???
 
  #6  
Old 10-18-19, 09:26 AM
Member
Join Date: Sep 2019
Location: Canada
Posts: 381
Received 34 Votes on 33 Posts
Download an app and check the signal strength at the modem and where you are using the Chromebook.

If the router has antennas on it then sometimes moving them can help.
Sometimes rotating the router can help.
Sometimes moving the router around a bit can help.
Could also try a different channel.

If all else fails you could try a WiFi booster. You will probably loose some speed but gain signal strength.
 
  #7  
Old 10-18-19, 12:36 PM
Member
Join Date: Sep 2009
Location: USA
Posts: 497
Received 0 Votes on 0 Posts
5g is likely part of the problem. It doesn't go through objects or cover as far as 2.4g.

Try using the 2.4g band and see if that helps. Yes you'll lose speed but it may increase reliability.
 
  #8  
Old 10-18-19, 02:45 PM
Utterly-NutZ's Avatar
Member
Join Date: Sep 2019
Location: Canada
Posts: 16
Received 0 Votes on 0 Posts
If you live in a busy neighbourhood, and the router is using defaults, then it might be the channel that you are using. The usual suspects are channel 1, 6 & 11; you may want to change that if you know how so that you are not on one with piles of traffic
You can use this tool to scan wifi around you and see what channels are most used to determine what you should change to WifiInfoView - WiFi Scanner for Windows 10/7/8/Vista
 
  #9  
Old 10-18-19, 02:50 PM
Davejb's Avatar
Member
Join Date: May 2002
Location: USA
Posts: 810
Received 0 Votes on 0 Posts
If you live in a busy neighbourhood, and the router is using defaults, then it might be the channel that you are using. The usual suspects are channel 1, 6 & 11; you may want to change that if you know how so that you are not on one with piles of traffic
To expand on the above, also never use anything other than 1, 6, or 11 due to channel overlap, pick the best one (least used and/or lowest signal strength in your area) of the 3.
 
  #10  
Old 10-18-19, 08:06 PM
Member
Join Date: Nov 2012
Location: USA
Posts: 1,262
Received 28 Votes on 23 Posts
For some time now my laptop (2012 Lenovo) farthest from the modem will frequently disconnect from my wireless home network (Comcast).
For older laptop first check the manufacturer's website to see if they have any updated WiFi drivers for your model.
There can be a HUGE difference between using the "average" Windows driver, and using the driver/program that is designed for the laptop hardware.

Example, I had a Dell laptop that was horrible at connecting when using standard XP WiFi drivers, but the Belkin driver was rock-solid (and showed probably 3x the number of WiFi connections, AND allowed you to choose between WiFi channels.
BUT the Belkin driver was a pain to use.

This morning I installed a new modem and the problem is worse, with it disconnecting every few minutes.
Comcast claims up to a gig. I am actually getting under 50 megs. Any ideas out there?
The 2012 Lenovo probably doesn't even have Gigabit WiFi.

Gigabit WiFi aka "5g" IS faster when closer, but it will NOT go through masonry walls, or fire-rated sheetrock. Many newer routers have "duplicate" WiFi, which supports two networks (SSID) which are usually "ABC123" and "ABC123-guest".

You might try setting the guest WiFi down to 802.11g to force it to broadcast a stronger but slower signal.
 
  #11  
Old 10-21-19, 09:18 PM
maarkr's Avatar
Member
Join Date: Mar 2014
Location: United States
Posts: 312
Received 4 Votes on 2 Posts
u need a stronger router... like an ac3000 mimo esp if you have other devices using wifi
 
  #12  
Old 10-22-19, 08:49 AM
Member
Join Date: Nov 2012
Location: USA
Posts: 1,262
Received 28 Votes on 23 Posts
Re-purpose the OLD router as a 2nd WiFi access point.

Most consumer "modems/routers" from Comcast combine a modem/router/wifi.
You can usually de-activate the modem function and then place the OLD router in the distance part of the home to provide better WiFi coverage.

You connect the old router to the new router by Ethernet cable, OR by the cable-tv cable.

Example, I've got FIOS, with 3 routers-

The newest-router, main router, is a 5g-gigabit "black shard" G1100 modem/router/WiFi in the main part of the house.

The old-router, a "red chicklet" Actiontek gigabit is out in the garage/workshop/office, connected to the main by 200' o outdoor grade ethernet cable.

The old-old-router a "black chicklet" Actiontek 100mb, is in the house, in an addition, and connected to the main modem/router by the cable tv cable (using a splitter at the cable box).

So, if you've still got the OLD router, you MIGHT be able to add another WiFi station just by re-configuring the old router and getting a cable splitter. Or, you might have to run some Ethernet cable, but there are plug-into the power outlet adapters that let you use the existing copper wire of the electric system as "built in" Ethernet cabling.
 
  #13  
Old 10-22-19, 05:38 PM
Join Date: Aug 2012
Location: USA
Posts: 104
Received 4 Votes on 3 Posts
Check the wireless channel that the modem/router is using. Almost always, they are set to "auto", which means they can change channels when they feel like it. Manufacturers use this setting as the default because they feel it will work out of the box for non-technical users. And it will, but not for long if there's traffic around. If the router changes channels, devices lose the connection and have to search for it to restore it. It is much better to set the router to a fixed channel.

Channels 1, 6, and 11 are recommended because they don't overlap with each other. You should do a wireless scan as recommended above to find which of those 3 channels has the least traffic on it. Of course, neighbors using adjacent channels like 2, 7, or 10 will cause interference, so look at those also. Same-channel interference is better than adjacent-channel interference.
 
  #14  
Old 10-23-19, 11:31 AM
Member
Join Date: May 2010
Location: USA
Posts: 436
Received 13 Votes on 10 Posts
All AC-band devices have the same (FCC-prescribed) power limits so AC3000 isn't any 'stronger" than AC450. AC3000 has a higher data rate than AC450 because it supports multiple spatial streams where AC450 only supports one.

Even if it were more powerful that's no guarantee it would extend the range (or improve connectivity) because wireless communication is a 2-way street. Each device has to be able to "hear" the other or connectivity will fail so ultimate rage is typically determined why whichever device "shouts" the weakest.

And if laptops, notebooks or tablets are involved, they typically are the weak link because the configuration of their antennas is compromised in the interest of making the device as small/thin/light [pick one] as possible. And antennas of compromised design don't make optimal use of whatever transmission power is available. Which is why enthusiasts sometimes resort to jury-rigging a DIY external antenna onto their laptop. A higher antenna gain likely will improve both transmission and reception 'power' but might also produce a more directional signal pattern..


Why High Power Routers Don't Improve Range
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: