Two routers = two networks?

Old 03-04-21, 09:40 AM
Thread Starter
Join Date: Jul 2019
Posts: 46
Received 0 Votes on 0 Posts
Two routers = two networks?

Quick synopsis: We have internet/wireless cable through the same company. I have a separate router & modem. The router is an Actiontec needed for our wireless cable. Our WiFi is spotted in some areas of the house. Our company sent us a Eero router and one Beacon. I have plugged the Eero into the Actiontec. This creates two separate WiFi networks. Whats the best way to handle this? Split up devices on each? Is there any downfall to the routers competing with each other? Is there a way to make just one network between the two? Pros? Cons?
Old 03-04-21, 09:54 AM
Forum Topic Moderator
Join Date: Sep 2005
Location: USA
Posts: 5,761
Received 189 Votes on 169 Posts
It's usually easier to just have one good wifi network in your house. Once you have multiples, you'll have problems with this computer not being able to connect to that printer, etc. Plus you get more network contention that can cause all sorts of other problems that are difficult to troubleshoot.

If it were me, I'd probably ditch the Actiontec and just use the Eero as a router & wifi.

If you do decide to keep two wifi networks, make sure they set to use different channels from each other and your neighbors.
WRDIY voted this post useful.
Old 03-04-21, 01:52 PM
Bob14525's Avatar
Join Date: Jun 2013
Location: USA
Posts: 1,622
Received 29 Votes on 24 Posts
You can connect the two routers to be on the same network, with the second one effectively acting as a Wireless Access Point (WAP). That is exactly what I did in my home. The primary router is at one end of the house, while the TV is at the other end. I put the secondary router in my basement (attached to one of the floor joists) underneath the TV. As Zorfdt mentioned, set both routers to different channels to minimize interference between the two. Turn off DHCP on the secondary router, and connect an ethernet cable from one of the primary router LAN ports to one of the LAN ports on the secondary router (not the WAN port). You can give the secondary router the same SSID as the primary (or not, your choice).
Old 03-04-21, 02:03 PM
Join Date: Nov 2012
Location: USA
Posts: 2,053
Received 157 Votes on 138 Posts
Originally Posted by EGrant23
Whats the best way to handle this? Split up devices on each?
The easiest thing to do is get a smart phone app to look at the spectrum of WiFi channels that are LEAST used around you, (there are two sets of frequencies to check) and then log into the routers to do three things
First - you want all the routers to broadcast on different channels, which don't overlap (generally you want 3 channels of distance between WiFi channels. Preferably you want channels that are "little used" e.g. your neighbors use WiFi channel #6, you want to use #3 or #9 instead (thus the scanning app above).

Second, set the secondary router(s) to broadcast with the same SSID, password and security settings as the main router. This lets your WiFi devices easily switch from one router to the other by using a single SSID.

Third, check to see if you have any options for "guest networks" among the routers. Many newer routers will have an option for a 2nd set of 5G WiFi which you can also set to the same SSID, password and security settings.
Old 03-05-21, 09:47 AM
Join Date: Jan 2008
Location: Southeastern Pennsylvania
Posts: 3,341
Received 38 Votes on 37 Posts

The router is an Actiontec needed for our wireless cable.
Are you sure that’s correct?
Old 03-05-21, 12:51 PM
Thread Starter
Join Date: Jul 2019
Posts: 46
Received 0 Votes on 0 Posts
Do I know for sure that my cable won't work with my Eero router? I guess I don't- just going off what they told me as the reasoning for needing a separate modem & router. I currently have the Eero plugged into the Actiontec and the Beacon is providing the WiFi coverage in areas where it was spotty before so the system is working great as is - just dislike the two networks.
Old 03-05-21, 02:04 PM
Join Date: Sep 2002
Location: welland ontario
Posts: 7,886
Received 326 Votes on 281 Posts
Try turning off the wifi on the one router. If you log into the router settings you might have an options to turn off wifi.

Thread Tools
Search this Thread
Ask a Question
Question Title:
Your question will be posted in: