KitchenAid Electric-Convection Wall Oven problem

Old 11-30-04, 02:16 PM
Thread Starter
Join Date: Sep 2004
Location: So Cal
Posts: 123
Upvotes: 0
Received 0 Upvotes on 0 Posts
KitchenAid Electric-Convection Wall Oven problem

There is an indicator for the temperature probe on the display when the probe is plugged into the side of the oven, at which time another display come on so the internal temperature can be set.

When the probe is removed from the oven the display should not be on or displaying.

I have tried cycling the power to the oven - no change

Plugging the probe in again and making sure it is in all the way, but the display to set the temperature is not displayed.

Any ideas?

I have also tried to find a repair manual for this model, but have not been succesful.
Old 12-01-04, 07:18 PM
Visiting Guest
Posts: n/a
Check the probe first

I suggest testing the resistance of the probe first to see if it's ok. Also, check the connections and wiring closely. There should be a tech sheet on the oven someplace, maybe inside the controls area. If no sheet, try looking up a Whirlpool help line phone # on thr Net. I hope the problem is not the electronic oven control [EOC] coz they are $$$. Unfortuneately, they somewhat of are a common failure. Can you post the model #? Let us know how you make out.

Thread Tools
Search this Thread
Ask a Question
Question Title:
Your question will be posted in: