Indicator light on electric range won't shut off

Old 01-30-05, 12:43 PM
Visiting Guest
Posts: n/a
Indicator light on electric range won't shut off

I recently purchased a house with a Roper range top, model # 2178X00. Three of the four burners worked. I checked the element, which works fine, and changed the switch, the receptacle for the element, and the wires. The old switch had all the wires removed from it except the one going to the indicator light. Now the burners all work, but the indicator light is on all the time. I tried disconnecting it from the new switch, even hooking it up to the old switch, but the indicator light is always on. I have disconnected the lead to the indicator light temporarily, but I would like to fix it. Any ideas?
Old 01-31-05, 09:42 PM
nomind's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Nov 2004
Location: langley, in sunny fraser valley, bc , near vancouver
Posts: 1,070
Upvotes: 0
Received 0 Upvotes on 0 Posts
Hi gsquared,
- sorry , I'm in a rush at the moment, but there is an anwer to this problem in the last week or two. Please look through old threads and you'll find it.

Do it Right - Do it once.

Thread Tools
Search this Thread
Ask a Question
Question Title:
Your question will be posted in: