Clothes Washer Water issue


  #1  
Old 07-23-06, 07:37 AM
2
Member
Thread Starter
Join Date: Aug 2002
Posts: 139
Received 0 Votes on 0 Posts
Clothes Washer Water issue

I have a Maytag Neptune front loading clothes washer that is about 3 yrs old. We have noticed recently an odor (like sewer or stagnant water) when you open either the door or the detergent lid. This is usually after the washer hasn't been used for a day or two. I also noticed that if you rotate the drum that there is still water in the machine, but you can't see water in the drum. Are these machines suppose to pump ALL the water out or not?
 
  #2  
Old 07-23-06, 05:08 PM
bambiblaster's Avatar
Member
Join Date: Mar 2005
Location: South Central Pa
Posts: 810
Received 1 Vote on 1 Post
Welcome to 1 of the top maytag problems... the water you here is in the balance ring in front... Supposed to be there.... All washers hold water at the bottom.. the pumps cant gt all of it out... you need to clean the dispenser and inside where it goes and every other month run a hot water cycle threw with 1 cup of bleech... and also take a rag with bleech on it and wipe the boot at least 1 every 2 weeks... There was a cla action suet on maytag but you missed out on it....
 
  #3  
Old 02-22-08, 11:34 AM
B
Member
Join Date: Feb 2008
Posts: 4
Received 0 Votes on 0 Posts
Smile water not draining/black marks on clothes

I have a GE top load machine. I also can hear water under the basket. We keep getting black marks on our clothes and are wondering if it's from the water under the basket. We never had this problem until we moved into this house. I would appreciate any ideas on what we can do to eliminate the problem.
 
  #4  
Old 02-22-08, 07:06 PM
bambiblaster's Avatar
Member
Join Date: Mar 2005
Location: South Central Pa
Posts: 810
Received 1 Vote on 1 Post
Originally Posted by bookwrm00 View Post
I have a GE top load machine. I also can hear water under the basket. We keep getting black marks on our clothes and are wondering if it's from the water under the basket. We never had this problem until we moved into this house. I would appreciate any ideas on what we can do to eliminate the problem.
your water sound is at the top of the basket... you may want to remove your agitator and bell cup to check for a upper oil leak..ref link below


http://www.applianceaid.com/newpics/GE-new-agitator.JPG
 
  #5  
Old 02-23-08, 07:43 PM
B
Member
Join Date: Feb 2008
Posts: 4
Received 0 Votes on 0 Posts
Wanted to also let you know that this is the 3rd washer we have had at this house (we moved in 1999). We have had problems with all 3 (black marks on clothes). We never had this problem at our old house. I will have my husband check for the oil leak.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: