Freezer Defrost Board

Reply

  #1  
Old 03-22-07, 06:52 AM
S
Member
Thread Starter
Join Date: Feb 2005
Location: US
Posts: 91
Received 0 Votes on 0 Posts
Freezer Defrost Board

For the third time in six months, my freezer on my Kenmore (made by Whirlpool) side-by-side is not defrosting and I had to use my hairdryer to melt the ice in order to get the refrigerator to start cooling. Twice (last September and December), the repair company I hired replaced the circuit board as they said it was a bad defrost element. I refuse to believe this is yet another bad circuit board. Each time the refrigerator works fine for about 3 months and then I notice a warmer refrigerator and frost on the back of my freezer. I called another repair company this morning who said they had a similar problem with a side-by-side and they themselves replaced the circuit board 4 times before checking the schematics (sp?) and replacing the evaporator fan. Problem solved. Does this sound reasonable to you and will I need to call the original company because this circuit board is now truly bad because of a bad evaporator fan?
 
Sponsored Links
  #2  
Old 04-06-07, 10:53 AM
H
Member
Join Date: Nov 2002
Location: Massachusetts
Posts: 1,824
Received 1 Vote on 1 Post
warranty

the parts should be under waranty (less than 1 year).
charge should be labor only.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: