Whirlpool Dishwasher - food grinder clogged

Reply

  #1  
Old 11-16-07, 08:09 AM
Member
Thread Starter
Join Date: Mar 2006
Posts: 38
Upvotes: 0
Received 0 Votes on 0 Posts
Whirlpool Dishwasher - food grinder clogged

I have a Whirlpool GU1200XTLQ0 dishwasher. It has an internal "food grinder" that chops up food particles and then filters them through a screen before the water gets to the pump. When this screen gets clogged, the pump doesn't get much water so the dishwasher doesn't wash - no output pump pressure. When I clean the screen, the problem is completely resolved, but lately that solution only seems to last for 5-10 wash cycles and I have to clean the screen again. It doesn't appear that the little spinner/chopper is properly engaging to chop the food - the screen is just clogged with food particles.
None of the small parts seem worn, damaged, or broken, but it is as if the spinner isn't spinning so maybe I've reassembled something incorrectly.

Ideas or suggestions would be appreciated.
 
Sponsored Links
  #2  
Old 11-16-07, 10:54 AM
Member
Thread Starter
Join Date: Mar 2006
Posts: 38
Upvotes: 0
Received 0 Votes on 0 Posts
Update - problem solved

I replaced the "chopper assembly" which is the screen, the chopper blade, and the plastic shaft (less than $20). Comparing the new part with the old made the problem obvious - and the dishwasher now runs great.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description:
Your question will be posted in: