GE Potscrubber 600 DW problem

Reply

  #1  
Old 11-04-10, 09:00 AM
T
Member
Thread Starter
Join Date: Feb 2005
Location: Southeast USA
Posts: 1,067
Received 0 Votes on 0 Posts
GE Potscrubber 600 DW problem

First of all thank you for reading and any advice.

I have a GE Potscrubber 600 at least 21 plus yrs old. It has been a workhorse although quite noisy but I suppose that is typical for a mdl that age. It is to be replaced when I do my kitchen overhaul in the spring.

This is the problem. I normally use the normal wash/light cycle setting with energy saver(no heating dry). However, I notice the last several washes that mdl will not go into final drying cycle(without heating element) as it usually does. The control knob just stops so I rotate it into off position.

Could this be a defective control knob that needs replacing or is there something more at work here?

I hope I have explained the problem clearly.

Thank you again.

 
Sponsored Links
  #2  
Old 11-05-10, 01:47 PM
T
Member
Thread Starter
Join Date: Feb 2005
Location: Southeast USA
Posts: 1,067
Received 0 Votes on 0 Posts
gosh.

is my post unclear?

what about it appliance pros?

thx
 
  #3  
Old 11-05-10, 04:55 PM
E
Banned. Rule And/Or Policy Violation
Join Date: May 2007
Location: Wisconsin
Posts: 8,627
Received 0 Votes on 0 Posts
Since there are no safety items to keep it from advancing, and since it stops advancing, I'd say that you unfortunately have something wrong in the timer, unless you can clearly tell the knob itself is hanging up on something.
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: