Kenmore Series 90 Thermostat Problem

Reply

  #1  
Old 11-27-10, 04:16 PM
D
Member
Thread Starter
Join Date: Jun 2008
Location: Long Island
Posts: 45
Received 0 Votes on 0 Posts
Kenmore Series 90 Thermostat Problem

I ahve a Kenmore series 90 clothes dryer , replace a bad heating coil last year and it has worked fine until recently . I makes heat , but it will take at least two 90 minute cycles to dry a regular load . I check all the thermostats , two next to the heating coil and two on the exhaust . All thermostats and the coil showed resistance on my multi meter except for the thermostat on the lower portion of the exhaust . It is the only one with four prongs(all the others have two) , i get resistance on the larger silver prongs but not on the brass ones . Does any know if this would mean that this is the problem , I believe that its called the high limit thermostat.
Thanks in advance.
[/IMG]

 
Sponsored Links
  #2  
Old 11-28-10, 05:13 AM
pugsl's Avatar
Forum Topic Moderator
Join Date: Mar 2008
Location: United States
Posts: 9,029
Received 74 Votes on 67 Posts
Clean out the vent to the outside, Most common problem with dryers. Thermostat with 4 prongs is temp control and it is working, Need model # to help better
 
Reply
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: