Kenmore Ultra Wash Dishwasher Model 665-15819990

Reply

  #1  
Old 02-10-13, 09:55 AM
G
Member
Thread Starter
Join Date: Jul 2008
Location: nc
Posts: 27
Received 0 Votes on 0 Posts
Kenmore Ultra Wash Dishwasher Model 665-15819990

Unit will not drain..I have checked the drain line at the machine and it isn't clogged. The unit works fine until it goes into the drain cycle then it cuts off and leaves water in the tub..I don't see a separate water pump so it must be included in the main motor..the unit is 12 yrs old and worked well up until this point..is it worth fixing or is it time for the dishwasher graveyard?..thanks in advance for any suggestions.
 
  #2  
Old 02-10-13, 10:25 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 60,936
Received 1,351 Votes on 1,249 Posts
Your machine has an integrated pump system. It could be as simple as a clogged filter or a damaged impeller. I've left you a link to the pictorial layout and parts list. Using the pictorial view below you're going to need to disassemble sump assy to determine the issue and then order parts. You may also want to check valve.....part # 15 .....located in drain line for a clog.

After clicking on link...... click on "view full size" under small pic. The pic will now open in a new window. Click on that new pic and it will be a large view that you can move around with your cursor.

http://www.searspartsdirect.com/part...&prst=&shdMod=



The following link is from a different site. Shows you the rebuild kit and they have a video to show you what is involved in the process.

Whirlpool 675806 - Drain and Wash Impeller Kit | PartSelect
 

Last edited by PJmax; 02-10-13 at 10:48 AM. Reason: Added second link
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description:
Your question will be posted in: